Error still here, with: 5.15.0-56-generic #62-Ubuntu SMP Tue Nov 22
19:54:14 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  kworker high CPU usage: issue with xhci_hub_control from xhci_pci
  kernel module

Status in linux package in Ubuntu:

Bug description:
  Using Ubuntu 22.04, as of yesterday night upon rebooting the framework
  laptop (which had not been rebooted for several weeks), the fans come
  on strong and I see, with top, a kworker process at nearly 100% CPU
  utilization, which makes the laptop unusable.

  I have an early Framework laptop with an 11th Gen Intel(R) Core(TM)
  i7-1165G7 @ 2.80GHz.

  I removed all USB-c expansion cards except for one with an USB-c pass
  through, to no avail.

  With perf I have been able to determine that the xhci_hub_control and
  perhaps xhci_bus_suspend are at fault. As a matter of fact, the laptop
  cannot suspend any more, when it was working flawlessly until the

  $ sudo apt install linux-tools-common linux-tools-$(uname -r)
  $ sudo -i
  # echo -1 > /proc/sys/kernel/perf_event_paranoid
  # perf record
  # perf report

  Samples: 125K of event 'cycles', Event count (approx.): 142991820424
  Overhead  Command          Shared Object                  Symbol
  54.11%  kworker/5:2+usb  [kernel.kallsyms]              [k] xhci_hub_control  
  7.94%  kworker/5:2+usb  [kernel.kallsyms]              [k] xhci_bus_suspend   
  0.98%  kworker/5:2+usb  [kernel.kallsyms]              [k] kfree              
  0.86%  kworker/5:2+usb  [kernel.kallsyms]              [k] 

  What can be done to address this issue with a kworker?

  I suspect perhaps the new kernel is at fault. I tried rebooting to the
  prior kernel 5.15.0-47-generic and 5.15.0-46-generic, but with the
  same result.

  What has changed? What can be done about this kworker and the

  A temporary solution:

  $ sudo modprobe -r xhci_pci

  … which results in the kworker process disappearing from `top`
  (reduced CPU usage to near zero), the fans wind down, and
  unfortunately the ethernet expansion bay doesn’t work anymore but at
  least wifi does. Keyboard and touchpad also work. And suspend with
  deep also work well, just tested it.

  I assume other expansion bays will stop working too, but the laptop is
  at least charging: the USB-c pass-through works.

  See also:

  ProblemType: Bug
  DistroRelease: Ubuntu 22.04
  Package: linux-image-5.15.0-48-generic 5.15.0-48.54
  ProcVersionSignature: Ubuntu 5.15.0-48.54-generic 5.15.53
  Uname: Linux 5.15.0-48-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu82.1
  Architecture: amd64
   /dev/snd/controlC0:  albert     4870 F.... pulseaudio
  CasperMD5CheckResult: unknown
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Sep 26 18:14:26 2022
  InstallationDate: Installed on 2022-03-11 (199 days ago)
  InstallationMedia: Ubuntu 20.04.4 LTS "Focal Fossa" - Release amd64 (20220223)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  Lsusb-v: Error: command ['lsusb', '-v'] failed with exit code 1:
  MachineType: Framework Laptop
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/BOOT/ubuntu_ezm1f9@/vmlinuz-5.15.0-48-generic 
root=ZFS=rpool/ROOT/ubuntu_ezm1f9 ro quiet splash nvme.noacpi=1 
mem_sleep_default=deep vt.handoff=1
   linux-restricted-modules-5.15.0-48-generic N/A
   linux-backports-modules-5.15.0-48-generic  N/A
   linux-firmware                             20220329.git681281e4-0ubuntu3.5
   1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: Upgraded to jammy on 2022-04-28 (150 days ago) 07/19/2022
  dmi.bios.release: 3.16
  dmi.bios.vendor: INSYDE Corp.
  dmi.bios.version: 03.10
  dmi.board.asset.tag: * FRANBMCP0B
  dmi.board.vendor: Framework
  dmi.board.version: AB
  dmi.chassis.asset.tag: FRANBMCPAB1484011X
  dmi.chassis.type: 10
  dmi.chassis.vendor: Framework
  dmi.chassis.version: AB
dmi:bvnINSYDECorp.:bvr03.10:bd07/19/2022:br3.16:svnFramework:pnLaptop:pvrAB:rvnFramework:rnFRANBMCP0B:rvrAB:cvnFramework:ct10:cvrAB:skuFRANBMCP0B: FRANBMCP Laptop
  dmi.product.sku: FRANBMCP0B
  dmi.product.version: AB
  dmi.sys.vendor: Framework

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to