This bug is missing log files that will aid in diagnosing the problem.
While running an Ubuntu kernel (not a mainline or third-party kernel)
please enter the following command in a terminal window:

apport-collect 2018125

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  do-release-upgrade fails due to full zfs partition

Status in linux package in Ubuntu:

Bug description:
  I used do-release-upgrade to upgrade from 22.10 x86-64 to 23.10.
  Towards the end of the upgrade, it rebooted, but stuck me in the recovery 
  I enabled networking and opened a root shell.
  1. Networking was not working. I fiddled with this for days, and could not 
get networking working. I tried starting NetworkManager, playing with rfkill, 
and a few other things, but, ultimately, could not get networking working.
  2. The problem that seemed to kill the upgrade was the zfs boot partition 
being too full for the new image, even though the new image was present. After 
a few days I found a way to remove old snapshots and created lots of free space 
on /boot. Linux still doesn't boot.

  Ultimately, if FOSS is supposed to be a good thing, and attract non-
  sysadmins, it should be easy to install/upgrade.

  1. do-release-upgrade should be able to deal with full filesystems,
  whether they're zfs or ext4 or the other front-running file systems,
  giving the user the tools to remove snapshots and/or files to make the
  new upgrade/release work as flawlessly as it can. I should be able to
  convert a zfs partition to ext4, (or vice versa) and get on with my
  real work.

  2. When the user is dumped into the recovery console, give him more
  tools to work with. There should be, at the very least, a way to get
  the network working when you press "enable networking" (not by having
  to download and figure out how to use network-tools, ifconfig, rfkill,
  dhclient, etc.), and deal with and fix ZFS issues.

  I know this isn't going to be fixed by the weekend, so I'm considering
  3 "nuclear" options, in decreasing order of desirability: (1) reformat
  the zfs boot partition as ext4, then copy the (saved) contents of
  /boot into the pristine partition. (2) Reinstall 23.04 from the thumb
  drive. I learned, decades ago, to keep my user partition on a separate
  drive, so it should be safe. What I'll lose is my network and wifi
  settings and printer setups. There are, undoubtedly other things that
  will have to be recovered, but those are the most important. (3) Pay
  through the nose for an Apple. I'd have to learn a new UI and transfer
  my files somehow, and bow down to my kids who have been pushing for me
  to get off this old Linux thing. "You'll have to pry my cold dead
  fingers off my Linux computers..."

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to