I ran apport-collect, but got undesirable results:
% apport-collect 2018125
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 1343, in 
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 1119, in 
    address_info = socket.getaddrinfo(host, port, 0, socket.SOCK_STREAM)
  File "/usr/lib/python3.11/socket.py", line 962, in getaddrinfo
    for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -3] Temporary failure in name resolution

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/apport-cli", line 436, in <module>
    if not app.run_argv():
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 966, in run_argv
    return self.run_update_report()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 780, in 
    if not self.crashdb.can_update(self.args.update_report):
  File "/usr/lib/python3/dist-packages/apport/crashdb_impl/launchpad.py", line 
586, in can_update
    bug = self.launchpad.bugs[crash_id]
  File "/usr/lib/python3/dist-packages/apport/crashdb_impl/launchpad.py", line 
170, in launchpad
    self.__launchpad = Launchpad.login_with(
  File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 700, in 
    return cls._authorize_token_and_login(
  File "/usr/lib/python3/dist-packages/launchpadlib/launchpad.py", line 451, in 
    credentials = authorization_engine(credentials, credential_store)
  File "/usr/lib/python3/dist-packages/launchpadlib/credentials.py", line 625, 
in __call__
    request_token_string = self.get_request_token(credentials)
  File "/usr/lib/python3/dist-packages/launchpadlib/credentials.py", line 640, 
in get_request_token
    authorization_json = credentials.get_request_token(
  File "/usr/lib/python3/dist-packages/launchpadlib/credentials.py", line 194, 
in get_request_token
    response, content = _http_post(url, headers, params)
  File "/usr/lib/python3/dist-packages/launchpadlib/credentials.py", line 108, 
in _http_post
    ).request(url, method="POST", headers=headers, body=urlencode(params))
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 1701, in 
    (response, content) = self._request(
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 1421, in 
    (response, content) = self._conn_request(conn, request_uri, method, body, 
  File "/usr/lib/python3/dist-packages/httplib2/__init__.py", line 1350, in 
    raise ServerNotFoundError("Unable to find the server at %s" % conn.host)
httplib2.error.ServerNotFoundError: Unable to find the server at launchpad.net

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  do-release-upgrade fails due to full zfs partition

Status in linux package in Ubuntu:

Bug description:
  I used do-release-upgrade to upgrade from 22.10 x86-64 to 23.10.
  Towards the end of the upgrade, it rebooted, but stuck me in the recovery 
  I enabled networking and opened a root shell.
  1. Networking was not working. I fiddled with this for days, and could not 
get networking working. I tried starting NetworkManager, playing with rfkill, 
and a few other things, but, ultimately, could not get networking working.
  2. The problem that seemed to kill the upgrade was the zfs boot partition 
being too full for the new image, even though the new image was present. After 
a few days I found a way to remove old snapshots and created lots of free space 
on /boot. Linux still doesn't boot.

  Ultimately, if FOSS is supposed to be a good thing, and attract non-
  sysadmins, it should be easy to install/upgrade.

  1. do-release-upgrade should be able to deal with full filesystems,
  whether they're zfs or ext4 or the other front-running file systems,
  giving the user the tools to remove snapshots and/or files to make the
  new upgrade/release work as flawlessly as it can. I should be able to
  convert a zfs partition to ext4, (or vice versa) and get on with my
  real work.

  2. When the user is dumped into the recovery console, give him more
  tools to work with. There should be, at the very least, a way to get
  the network working when you press "enable networking" (not by having
  to download and figure out how to use network-tools, ifconfig, rfkill,
  dhclient, etc.), and deal with and fix ZFS issues.

  I know this isn't going to be fixed by the weekend, so I'm considering
  3 "nuclear" options, in decreasing order of desirability: (1) reformat
  the zfs boot partition as ext4, then copy the (saved) contents of
  /boot into the pristine partition. (2) Reinstall 23.04 from the thumb
  drive. I learned, decades ago, to keep my user partition on a separate
  drive, so it should be safe. What I'll lose is my network and wifi
  settings and printer setups. There are, undoubtedly other things that
  will have to be recovered, but those are the most important. (3) Pay
  through the nose for an Apple. I'd have to learn a new UI and transfer
  my files somehow, and bow down to my kids who have been pushing for me
  to get off this old Linux thing. "You'll have to pry my cold dead
  fingers off my Linux computers..."

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to