Hi,
I recently decided to try and make contributions to the kernel. I normally just 
use windows as my operating system so I decided to set up Slackware to develop 
on. I thought a good place to start would to actually compile the kernel and 
install it before I actually make any changes. I ran:
make O=/home/nathanael/KernelBuild localmodconfig
make O=/home/nathanael/KernelBuild

After getting it compiled I ran:
bash-4.3$ sudo make O=/home/nathanael/KernelBuild/ install_module install

but got this error:
make[1]: Entering directory '/home/nathanael/KernelBuild'
make[1]: *** No rule to make target 'install_module'.  Stop.
make[1]: Leaving directory '/home/nathanael/KernelBuild'
Makefile:180: recipe for target 'sub-make' failed
make: *** [sub-make] Error 2

I have tried looking around but haven't found anything that has been 
particularly useful in figuring this out. I am not sure what info might be 
relevant so I'll just let you know that I'm on Slackware 14.2 and trying to 
upgrade the Kernel from 4.4.208 to 5.6.0 and I am using ELILO instead of LILO. 
If anyone has any suggestions or can even just direct me to some resources that 
might have more info on what is going on with make install_module or the error 
that would be sick. Thanks.
_______________________________________________
Kernelnewbies mailing list
Kernelnewbies@kernelnewbies.org
https://lists.kernelnewbies.org/mailman/listinfo/kernelnewbies

Reply via email to