Hello,

Macro *compute_indices* in arch/arm64/kernel/head.S have a comment
as shown below:
        mov     \istart, \ptrs
        mul     \istart, \istart, \count
        add     \iend, \iend, \istart   // iend += (count - 1) * ptrs

I am wondering whether this comment should be change to 
"iend += count * ptrs".

Or am I misunderstanding this code?

Thanks

-Lio

_______________________________________________
Kernelnewbies mailing list
Kernelnewbies@kernelnewbies.org
https://lists.kernelnewbies.org/mailman/listinfo/kernelnewbies

Reply via email to