> Refactor the logic to match devices to pci_dev_acs_ops by factoring out > the device matching loop into its own routine, pci_dev_acs_ops_get(). > This eliminates duplicate code between pci_dev_specific_enable_acs() and > pci_dev_specific_disable_acs_redir(), and will also be used in a > subsequent commit to check if a device requires device-specific > enable_acs() during a Live Update. > > No functional change intended. > > Reviewed-by: Pranjal Shrivastava <[email protected]> > Reviewed-by: Pasha Tatashin <[email protected]> > Reviewed-by: Bjorn Helgaas <[email protected]> > Signed-off-by: David Matlack <[email protected]>
Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=7
