The old _do_fork() helper is removed in favor of the new kernel_clone() helper.
The latter adheres to naming conventions for kernel internal syscall helpers.

Cc: Greentime Hu <green...@gmail.com>
Cc: Yoshinori Sato <ys...@users.sourceforge.jp>
Cc: uclinux-h8-de...@lists.sourceforge.jp
Signed-off-by: Christian Brauner <christian.brau...@ubuntu.com>
---
/* v2 */
unchanged
---
 arch/h8300/kernel/process.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/h8300/kernel/process.c b/arch/h8300/kernel/process.c
index 83ce3caf7313..aea0a40b77a9 100644
--- a/arch/h8300/kernel/process.c
+++ b/arch/h8300/kernel/process.c
@@ -172,5 +172,5 @@ asmlinkage int sys_clone(unsigned long __user *args)
        kargs.exit_signal       = (lower_32_bits(clone_flags) & CSIGNAL);
        kargs.stack             = newsp;
 
-       return _do_fork(&kargs);
+       return kernel_clone(&kargs);
 }
-- 
2.28.0



_______________________________________________
Kgdb-bugreport mailing list
Kgdb-bugreport@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/kgdb-bugreport

Reply via email to