Hi, On Mon, May 15, 2023 at 4:21 PM Doug Anderson <diand...@chromium.org> wrote: > > Hi, > > On Fri, May 12, 2023 at 6:49 AM Daniel Thompson > <daniel.thomp...@linaro.org> wrote: > > > > On Wed, Apr 19, 2023 at 03:56:01PM -0700, Douglas Anderson wrote: > > > From: Sumit Garg <sumit.g...@linaro.org> > > > > > > Add a new API kgdb_smp_call_nmi_hook() to expose default CPUs roundup > > > mechanism to a particular archichecture as a runtime fallback if it > > > detects to not support NMI roundup. > > > > > > Currently such an architecture example is arm64 supporting pseudo NMIs > > > feature which is only available on platforms which have support for GICv3 > > > or later version. > > > > > > Signed-off-by: Sumit Garg <sumit.g...@linaro.org> > > > Tested-by: Chen-Yu Tsai <w...@csie.org> > > > Signed-off-by: Douglas Anderson <diand...@chromium.org> > > > --- > > > > > > (no changes since v1) > > > > > > include/linux/kgdb.h | 12 ++++++++++++ > > > kernel/debug/debug_core.c | 8 +++++++- > > > 2 files changed, 19 insertions(+), 1 deletion(-) > > > > > > diff --git a/include/linux/kgdb.h b/include/linux/kgdb.h > > > index 258cdde8d356..87713bd390f3 100644 > > > --- a/include/linux/kgdb.h > > > +++ b/include/linux/kgdb.h > > > @@ -199,6 +199,18 @@ kgdb_arch_handle_qxfer_pkt(char *remcom_in_buffer, > > > > > > extern void kgdb_call_nmi_hook(void *ignored); > > > > > > +/** > > > + * kgdb_smp_call_nmi_hook - Provide default fallback mechanism to > > > + * round-up CPUs > > > + * > > > + * If you're using the default implementation of kgdb_roundup_cpus() > > > + * this function will be called. And if an arch detects at runtime to > > > + * not support NMI based roundup then it can fallback to default > > > + * mechanism using this API. > > > + */ > > > + > > > +extern void kgdb_smp_call_nmi_hook(void); > > > > Concept looks sensible but this is a terrible name for aa command to > > round up the CPUs using smp_call... functions. Whilst it is true it that > > kgdb_roundup_cpus() does use kgdb_call_nmi_hook() internally that > > doesn't mean we should name functions after it. They should be named > > after what they are do, not how they do it. > > > > Something more like kgdb_roundup_cpus_with_smp_call() would be a much > > better name. > > Sounds good. I'm happy to spin with this rename, though I was kinda > hoping to drop ${SUBJECT} patch if folks were OK with patch #10 in > this series [1]. I personally think that's the right way to go but > it's unclear to me if arm64 maintainers will think it's a hack > (despite the fact that arm32 implements the "nmi" functions with > regular IPIs). > > For now, maybe I'll think positive thoughts and hope that folks will > have the time to review the series soon. If another few weeks go by > then I'll send a v9 with just your comments addressed. If nothing > else, maybe you can land the kgdb parts in a tree targeting v6.5 and > then when arm64 folks have the bandwidth then it will be easier to get > them landed. > > [1] > https://lore.kernel.org/r/20230419155341.v8.10.Ic3659997d6243139d0522fc3afcdfd88d7a5f030@changeid
Breadcrumbs: I've dropped this patch and several others in v9 [1] by embracing the idea of using a normal IPI as a fallback. [1] https://lore.kernel.org/r/20230601213440.2488667-1-diand...@chromium.org/ _______________________________________________ Kgdb-bugreport mailing list Kgdb-bugreport@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/kgdb-bugreport