I am not entirely sure what your intention exactly.
The message looks like a commit message rather than a request for
comments. Especially because I can not detect any questionmark, but I
will assumeit is a question anyways. It guess it requries quite some
May I suggest just naming it KICAD_LEGACY_CANVAS which can be set ON
or OFF? The _BUILD seems superfluous to me. Yes, I know this is
bikeshedding, it is just a suggestion afterall.
But really, I don't see any reason start doing this before GAL support
is added everywhere. It could possible be added while enabling GAL
support everywhere, but I think it might not be worth the effort
trying to add it. I think it might be easer to just rip it out when
that is going to happen directly rather than adding ifdefs.
But in reality, I like the switching concept we have in pcbnew right
now. It makes it very easy to compare the two canvasses because it
does not require a seperate build, and you can switch instantly.
2016-09-17 12:59 GMT+02:00 Simon Wells <swel...@gmail.com>:
> As legacy canvas in pcbnew is legacy is it worth conditional compiling
> all the code related and only used by legacy canvas based on a cmake
> option aka something like
> KICAD_BUILD_LEGACY_CANVAS with a default of ON, this will allow people
> who have no use for the legacy canvas as they have a truly functional
> opengl canvas to see in their usual workflow if anything is missing.
> I realise that wayne is waiting on a replacement non-gl dependent GAL
> canvas before removing legacy, but in the interim is it worth making
> it an option making less work later on when its time to remove it
> Mailing list: https://launchpad.net/~kicad-developers
> Post to : firstname.lastname@example.org
> Unsubscribe : https://launchpad.net/~kicad-developers
> More help : https://help.launchpad.net/ListHelp
Mailing list: https://launchpad.net/~kicad-developers
Post to : email@example.com
Unsubscribe : https://launchpad.net/~kicad-developers
More help : https://help.launchpad.net/ListHelp