I’ve attached the output from when I try to configure with the original file.
The version checking didn’t work for 7.1 for me either. It should be noted, that
I built OpenCascade from source, and I’ve tried to manually change it to point
to the Standard_Version header, but it still doesn’t parse it correctly with 
the same
error outputted.


From: Seth Hillbrand <seth.hillbr...@gmail.com>
Sent: Thursday, February 08, 2018 10:49 AM
To: Thomas Figueroa <tom_figue...@hotmail.com>
Cc: kicad-developers@lists.launchpad.net
Subject: Re: [Kicad-developers] [PATCH] Allow OpenCASCADE standard edition

Hi Thomas-

I will add this library to the include.  Odd that it wasn't required on Linux.  
Can you send me your CMakeOutput.log?  The version checking is pretty important 
and those files don't change, so I'd like to track down why it would work for 
7.1 but not for 7.2.


2018-02-08 7:29 GMT-08:00 Thomas Figueroa 
Hey Seth,

Working great with OpenCascade 7.2! I had to modify the Cmake file, though,
to include TKV3d in the library list. I get unresolved external link errors 
when compiling
s3d_plugin_oce otherwise (unresolved symbols SelectMgr_Selection, 
PrsMgr_PresentableObject, and AIS_InteractiveObject respectively).
I also had to remove the version checking, as it was unable to get the version 
via regex matching for some reason.


From: Seth Hillbrand<mailto:seth.hillbr...@gmail.com>
Sent: Tuesday, February 6, 2018 2:34 PM

Subject: Re: [Kicad-developers] [PATCH] Allow OpenCASCADE standard edition

I've updated this to allow use of OpenCascade 7.2 as well.

Nick, I added a few more helpful error messages to CMake file.  Let me know if 
you are still seeing the configure error with a clean cmake.


2018-02-02 12:47 GMT-08:00 Thomas Figueroa 
Hey Seth,

I was able to successfully use OpenCascade 7.1 and export using kicad2step!

Now to find out why…


From: Seth Hillbrand<mailto:seth.hillbr...@gmail.com>
Sent: Friday, February 2, 2018 11:10 AM
To: Thomas Figueroa<mailto:tom_figue...@hotmail.com>
Subject: Re: [Kicad-developers] [PATCH] Allow OpenCASCADE standard edition

Hi Thomas-

I located a windows machine to try this.  I suspect that this is an artifact of 
OpenCascade 7.2.  Can you test with OpenCascade 7.1?  I haven't tracked down 
exactly what changed in 7.2 but it appears that 7.0 and 7.1 work but 7.2 will 
require additional work in kicad2step.

Of note, OCCT 6.8 also works but 6.9 (and OCE 0.18, which is based on 6.9) do 
not work either.  This is due to a compiler optimization but appears to be a 
different issue than the 7.2 one.


2018-01-31 19:04 GMT-08:00 Thomas Figueroa 
Hello Seth,

I’ve had the opportunity to test this on Windows (MSVC, but I’ve had the same 
issue with MSYS2).
STEP models work great in the 3D viewer, and in the footprint module editor, 
just as in OCE.
Unfortunately, I cannot get the STEP export to work. I’ve had a run at using 
OpenCascade before
and encountered this exact same issue. As an example, I’ve attached an 
outputted file.
The following output is from the command line kicad2step:

20:31:07: C:\dev\kicad-personal\utils\kicad2step\pcb\oce_utils.cpp: fileType: 
  * no such file: ''

20:31:07: C:\dev\kicad-personal\utils\kicad2step\pcb\oce_utils.cpp: 
PCBMODEL::AddComponent: 574
  * no model for filename for ‘’

This repeats for every model. If you have any ideas, I’d be very willing to try 
them out.

- Thomas

From: Kicad-developers 
 On Behalf Of Seth Hillbrand
Sent: Monday, January 29, 2018 12:55 PM
To: KiCad Developers 
Subject: [Kicad-developers] [PATCH] Allow OpenCASCADE standard edition

​Hi All-

Currently, the build requires the opencascade community edition.  For various 
reasons, I need to have the current non-community edition of OpenCASCADE 
installed on my work machine.

The attached patch allows compiling KiCad with either the OpenCASCADE community 
edition or standard edition.

I've tested on a homebrew-based Mac install as well as Linux but haven't 
verified MSW, if someone would be willing to test it there, that would be 
great!  The basic search routines are lightly modified from FreeCAD's logic and 
keep their LGPL copyright on the CMake file.


Attachment: cmake-error.log
Description: cmake-error.log

Mailing list: https://launchpad.net/~kicad-developers
Post to     : kicad-developers@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kicad-developers
More help   : https://help.launchpad.net/ListHelp

Reply via email to