Ok, I just tried to do:

In [3]: wx.version()
Out[3]: '4.0.1 gtk3 (phoenix)'

I clearly also have python2-wxpython-phoenix installed. I just tried to
remove that from my system.

Now it seems to complete the cmake configure successfully. I guess the
patch works afterall :D

But I have a comment. Should we be a bit more helpful for the packager, to
tell him that he can temporarely disable the scripting options to make it
build, maybe also hint that we on do support gtk2 for the time being.

2018-02-19 22:28 GMT+01:00 Nick Østergaard <oe.n...@gmail.com>:

> Hello Maciej,
>
> I just tested your patch on archlinux. It does not seem to work properly,
> tested in a clean build dir. Even if I remove wxpython (with gtk3) and
> install wxpython-gtk2 (with gtk2 from AUR) it still complains that there is
> a mismatch. I have wxwidgets with gtk2 and gtk3 installed, taht is the
> packages wxgtk2 and wxgtk3.
>
> I see it says; "wxPython version 3.0 found."
>
> So the patch as is seems to be broken for me.
>
> 2018-02-17 21:03 GMT+01:00 Maciej Suminski <maciej.sumin...@cern.ch>:
>
>> In order to prevent faulty builds in case of wxPython/wxWidgets toolkit
>> mismatch [1,2] (gtk2 vs gtk3), I added a check in CMakeLists. I verified
>> it with Windows 7 and Linux, but I would love to hear from OSX users
>> that I do not break their build.
>>
>> Cheers,
>> Orson
>>
>> 1. https://forum.kicad.info/t/9493
>> 2. https://bugs.launchpad.net/kicad/+bug/1746753
>>
>> _______________________________________________
>> Mailing list: https://launchpad.net/~kicad-developers
>> Post to     : kicad-developers@lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~kicad-developers
>> More help   : https://help.launchpad.net/ListHelp
>>
>>
>
_______________________________________________
Mailing list: https://launchpad.net/~kicad-developers
Post to     : kicad-developers@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kicad-developers
More help   : https://help.launchpad.net/ListHelp

Reply via email to