I'm fine with renaming to SMD pads.
Right now the logic (implemented by Andrzej, not me by the way) assumes
that all pads are associated with footprints, and if footprint display is
turned off, hides pads (SMD and through hole)
Seems like lots of people have different opinions on what those switches
should do :-)

In my humble opinion, it would make more sense to hide everything *but* the
pads when you uncheck the footprint boxes, but some other people really
want the pads to be hidden so they can check for "stray traces" under the
pads.

So, we can keep tweaking this, but maybe not until after RC1 so we stop
delaying it any further :-)

-Jon

On Fri, Feb 23, 2018 at 3:38 PM, Jeff Young <j...@rokeby.ie> wrote:

> Hi Jon,
>
> Just playing with the new render palette.  It’s a big improvement.
>
> However, I noted that turning off Footprints turns off through-hole pads.
> Since we have a separate option for that, it’s counter-intuitive to have
> Footprints also control it.  (And, when one wants to see the copper and
> nothing else, you want pads without footprints.)
>
> Also, it’s easy to think Front Pads or Back Pads should show them.  I
> understand the distinction, but shouldn’t we name them Front SMD Pads and
> Back SMD Pads to make it clearer?
>
> Cheers,
> Jeff.
>
> > On 23 Feb 2018, at 15:35, jp charras <jp.char...@wanadoo.fr> wrote:
> >
> > Le 23/02/2018 à 16:12, Jon Evans a écrit :
> >> You can commit that, but I can't quite tell why there are two different
> functions ReFillRender() and
> >> SyncRenderStates(); they do mostly the same thing so it seems best to
> just collapse them into one to
> >> avoid bugs in the future.
> >> The attached patch removes SyncRenderStates -- please let me know if
> this makes sense to you also.
> >>
> >> Thanks,
> >> -Jon
> >>
> >
> > I committed you patch.
> >
> > It makes sense to me, and this is the right way to fix this issue.
> > Sometimes code cleanup is needed.
> >
> > Thanks.
> >
> >>
> >> On Fri, Feb 23, 2018 at 10:05 AM, jp charras <jp.char...@wanadoo.fr
> <mailto:jp.char...@wanadoo.fr>>
> >> wrote:
> >>
> >>    Le 23/02/2018 à 15:57, Jon Evans a écrit :
> >>> If you add a call to ReFillRender() at the top of 
> >>> PCB_LAYER_WIDGET::SyncRenderStates()
> instead of my
> >>> change, does it fix it?
> >>>
> >>
> >>    Yes, just adding the call fixes this issue.
> >>    Can I commit this fix?
> >>
> >>
> >>> On Fri, Feb 23, 2018 at 9:54 AM, jp charras <jp.char...@wanadoo.fr
> >>    <mailto:jp.char...@wanadoo.fr> <mailto:jp.char...@wanadoo.fr
> <mailto:jp.char...@wanadoo.fr>>>
> >>> wrote:
> >>>
> >>>      Le 23/02/2018 à 14:24, Jon Evans a écrit :
> >>>      > Hi JP, good catch, the attached fixes it for me
> >>>      >
> >>>      > -Jon
> >>>      >
> >>>      > On Fri, Feb 23, 2018 at 7:18 AM, jp charras <
> jp.char...@wanadoo.fr <mailto:jp.char...@wanadoo.fr>
> >>>      <mailto:jp.char...@wanadoo.fr <mailto:jp.char...@wanadoo.fr>>
> >>    <mailto:jp.char...@wanadoo.fr <mailto:jp.char...@wanadoo.fr>
> <mailto:jp.char...@wanadoo.fr
> >>    <mailto:jp.char...@wanadoo.fr>>>>
> >>>      > wrote:
> >>>      >
> >>>      >     Le 23/02/2018 à 01:04, Jon Evans a écrit :
> >>>      >     > Here are two more quick patches addressing some of the
> easier changes.
> >>>      >     > I have some other bugs to look at that seem more urgent,
> so I'm not going to work
> >>    on the right-click
> >>>      >     > menu or settings persistence.
> >>>      >     >
> >>>      >     > Thanks,
> >>>      >     > Jon
> >>>      >     >
> >>>      >
> >>>      >     Hi Jon,
> >>>      >
> >>>      >     There is a (minor but annoying) issue about patch:
> >>>      >
> >>>      >     "Only show microvia and blind/buried via settings if they
> are enabled"
> >>>      >
> >>>      >     When I load a board that have microvia and blind/buried
> vias allowed, the layer
> >>    manager does not
> >>>      >     show the microvia and blind/buried vias menuitems.
> >>>      >
> >>>      >     They are displayed only after opening and closing by OK
> button the Design Rules menu.
> >>>      >
> >>>      >     (Tested on W7/32bits)
> >>>      >
> >>>      >     --
> >>>      >     Jean-Pierre CHARRAS
> >>>
> >>>      With this patch, Pcbnew crashes when starting, but not always.
> >>>      I am thinking m_Layers->ReFillRender(); is called too early, when
> initializations are not yet
> >>>      finished
> >>>
> >>>      In fact it is called before m_Layers is initialized.
> >>>
> >>>      The fix is easy, but when loading a file, syncRenderStates(); is
> called
> >>>      (files_io.cpp line 592)
> >>>
> >>>      Perhaps the root issue is SyncRenderStates() is missing some
> initializations.
> >>>
> >>>
> >>>
> >>>      --
> >>>      Jean-Pierre CHARRAS
> >>>
> >>>
> >>
> >>
> >>    --
> >>    Jean-Pierre CHARRAS
> >>
> >>
> >
> >
> > --
> > Jean-Pierre CHARRAS
> >
> > _______________________________________________
> > Mailing list: https://launchpad.net/~kicad-developers
> > Post to     : kicad-developers@lists.launchpad.net
> > Unsubscribe : https://launchpad.net/~kicad-developers
> > More help   : https://help.launchpad.net/ListHelp
>
>
_______________________________________________
Mailing list: https://launchpad.net/~kicad-developers
Post to     : kicad-developers@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kicad-developers
More help   : https://help.launchpad.net/ListHelp

Reply via email to