I'm still not sure what the underlying issue is, but I do see some things that smell suspicious to me. These comments are as I read through the log.

gcc is 6.2.1. I have no idea if anyone else is using this recent a gcc. I don't think it should be a problem, but there have certainly been cases where a newer gcc handles something differently.


at the end of the cmake run, I don't see the usual output about the various things it has found. I don't know if you snipped it or if that might indicate some issue with the cmake output being incomplete.

that ending seems very abrupt to me. Try running make with a more verbose setting. It normally says more about what it is actually doing. No need to start from scratch, if you just run make in the existing build directory, it will skip the things that were done ok.

One more question - It looks like your build directory is right in the root of the source tree. This is not recommended, although it often does work. Try using a build directory outside the source tree.

The error does seem to be within the automoc stuff, which is just magic to me. (It is also where I am currently having problems with both the 4.8 and master branch builds in various different environments.)

Jack


On 10/14/2016 12:47 PM, Brendan Coupe wrote:
I was running make with -j 8. I eliminated that setting and ran it again
assuming this might show where the error is. The last part of the output
is copies below and the full log is attached.

​​
Scanning dependencies of target kmm_config_automoc
[ 11%] Automatic moc for target kmm_config
[ 11%] Built target kmm_config_automoc
[ 12%] Generating kmymoneysettings.h, kmymoneysettings.cpp
Scanning dependencies of target kmm_config
[ 12%] Building CXX object
kmymoney/CMakeFiles/kmm_config.dir/kmymoneyglobalsettings.cpp.o
kmymoney/CMakeFiles/kmm_config.dir/build.make:70: recipe for target
'kmymoney/CMakeFiles/kmm_config.dir/kmymoneyglobalsettings.cpp.o' failed
CMakeFiles/Makefile2:738: recipe for target
'kmymoney/CMakeFiles/kmm_config.dir/all' failed
Makefile:160: recipe for target 'all' failed


*
----
Brendan*

On Fri, Oct 14, 2016 at 9:17 AM, Brendan Coupe <bren...@coupeware.com
<mailto:bren...@coupeware.com>> wrote:

    I've attached the full log.

    Thanks,
    *
    ----
    Brendan*

    On Fri, Oct 14, 2016 at 8:29 AM, Jack
    <ostrof...@users.sourceforge.net
    <mailto:ostrof...@users.sourceforge.net>> wrote:

        On 2016.10.14 08 <tel:2016.10.14%2008>:55, Brendan Coupe wrote:

            ​I compared the output from the 2 systems. The line that
            happen right
            before it crashes​:

            [ 26%] Built target kmm_kdchart

            happens at 44% on the systems that completes the compile
            process.

            Not sure if that helps but it appears to be skipping something.



            *----Brendan*

            On Fri, Oct 14, 2016 at 5:44 AM, Brendan Coupe
            <bren...@coupeware.com <mailto:bren...@coupeware.com>>
            wrote:

            > Doug, Thanks for your quick reply.
            >
            > All kdepimlibs are installed on both systems. Any other ideas?
            >
            >
            >
            > *----Brendan*
            >
            > On Fri, Oct 14, 2016 at 1:23 AM, Doug Lytle <supp...@drdos.info 
<mailto:supp...@drdos.info>> wrote:
            >
            >> On 10/14/2016 01:28 AM, Brendan Coupe wrote:
            >>
            >> Both systems are running Fedora 24 64 bit. I assume I'm missing a
            >> dependency. Can anyone tell what is wrong?
            >>
            >>
            >> If I recall correctly, you'll need kdepimlibs development 
libraries
            >>
            >> Doug

        I wouldn't trust the % very much.  It seems very different on
        two different compiles for me which I would expect to be much
        more similar.  However, if you want help, you have to post the
        actual error.  What you posted was just the final report from
        make that it didn't succeed.  The real error is probably much
        higher in the output.  It may still not be obvious why it
        failed, but it will at lest tell the actual command which failed.

        Jack



Reply via email to