On 2018.02.08 19:48, Jack wrote:
On 2018.02.08 19:30, Jack wrote:
On 2018.02.08 19:13, Jack Ostroff wrote:
I just tried doing my monthly ofximports to update my investment accounts (Merrill Lynch). Based on some notation in the ofx produced by Merrill Lynch, certain transactions have their income assigned to the category "_Dividend". Oddly, however, I had closed this category in the past so it would not be used. Today, two transactions were imported and assigned to this category - but I now can't edit them, since it is not allowed to edit a transaction using a closed account. I know I can reopen the account, fix the transaction, and then re-close it - but isn't it a bug to assign a new transaction to a closed account?


(Well - the first message probably won't make it to the list anyway, since I sent from an unsubscribed account)

This is even stranger than I thought. The _Dividend category is NOT left over from previous use. KMM just created it. These two imported transactions are the ONLY transactions in this category. When I go to edit this category, the dialog says "New Account Dialog" but there is no indication of an open or closed status. If I try to delete the category, the list of other categories for assigning the transactions is empty, so I can't delete it.

I can "Accept" the transactions using it, which removes the yellow background color. However, I cannot (re)open it, I cannot delete it. I cannot edit the transactions using it. I cannot delete the transactions using it. Huh? Do I have to remove them by editing the kmy file?

Things get better. After doing everything I could with this account (marking the two imported transactions as "not marked" so I could reconcile the account at 31 Jan 2018, I tried to save, but got an uncaught error "Unknown account id 'A000149' in file /usr/portage/tmpdir/portage/app-office/kmymoney-5.0.0/work/kmymoney-5.0.0/kmymoney/mymoney/storage/mymoneyseqaccessmgr.cpp line 206. The problem is that that account (looking into the kmy file) IS the investment account with the problem transactions. I'm going to wait for tomorrow to look into the last saved copy of the file to see what it actually in there. I do have a recent enough backup to start again from one or two days ago, but I hate to have to do that, especially if I don't know I'll end up going down the same path again.

I get that uncaught error just doing a File/Close, no need to save.

Unfortunately, my last backup is too many days ago - just before I did the January reconcile for some other accounts, which was before I tried working on the Investment accounts. I'm going to keep all the various auto backup and most recent "bad" files to help with any troubleshooting, but it looks like I'm going to start over from my last known good backup, and leave the investment accounts alone until we know what the problem is.

I'll also try to create a test file which shows the error with a file ofx import of just the one day that includes those odd interest payments.

Jack

Reply via email to