https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20104

--- Comment #9 from M. Tompsett <mtomp...@hotmail.com> ---
Comment on attachment 73829
  --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=73829
Bug 20104: Update minimum version of Perl to 5.20

Review of attachment 73829:
 --> 
(https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=20104&attachment=73829)
-----------------------------------------------------------------

::: installer/install.pl
@@ +93,4 @@
>      $template->param( 'checkmodule' => 1 )
>        ; # we start with the assumption that there are no problems and set 
> this to 0 if there are
>  
> +    unless ( $] >= 5.020000 ) {    # Bug 20104

Then change this back to 5.010000 -- clearly the perldoc site needs
improvement. I was just trying to make sure the version of perl needed was
accurately reflected.

@@ +93,5 @@
>      $template->param( 'checkmodule' => 1 )
>        ; # we start with the assumption that there are no problems and set 
> this to 0 if there are
>  
> +    unless ( $] >= 5.020000 ) {    # Bug 20104
> +        $template->param( problems => 1, perlversion => '5.20', checkmodule 
> => 0 );

And this to 5.10

::: koha-tmpl/intranet-tmpl/prog/en/modules/installer/step1.tt
@@ +70,4 @@
>                          <p>I encountered some problems.</p>
>                          <ul>
>                              [% IF ( perlversion ) %]
> +                                <li>Your Perl version is out of date. Please 
> upgrade to a newer version of Perl (at least version [% perlversion %]).</li>

Because this refactor is worth keeping, I believe.

-- 
You are receiving this mail because:
You are watching all bug changes.
_______________________________________________
Koha-bugs mailing list
Koha-bugs@lists.koha-community.org
http://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-bugs
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to