https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29408
Bug ID: 29408
Summary: The datatables api wrapper is badly named
Change sponsored?: ---
Product: Koha
Version: master
Hardware: All
OS: All
Status: NEW
Severity: enhancement
Priority: P5 - low
Component: Architecture, internals, and plumbing
Assignee: [email protected]
Reporter: [email protected]
QA Contact: [email protected]
The dataTables Koha REST wrapper we added recently is badly named.. currently,
it's the very unspecific 'api'.. we should start using a consistent naming
convention for such JS wrapper functions.
In bug 29397 we introduce a minimal select2 wrapper and call it kohaSelect.. I
propose we take that as inspiration and rename the dataTables function from
'api' to 'kohaTable'.
Thus, creating a new API driven dataTable would become:
$(".selector").kohaTable(usual stuff here);
--
You are receiving this mail because:
You are watching all bug changes.
You are the assignee for the bug.
_______________________________________________
Koha-bugs mailing list
[email protected]
https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-bugs
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/