https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41530

--- Comment #6 from Katrin Fischer <[email protected]> ---
Created attachment 202027
  -->
https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=202027&action=edit
Bug 41530: Rename item_type => item_type_id in suggestions API spec

Following the API consistency work in bug 41456, this patch renames
the item_type field to item_type_id in the suggestions API definition.

The field should only be named item_type when it contains an embedded
object (type: object/null). When it contains a foreign key ID
(type: string/null), it should be named item_type_id for consistency.

Changes:
- Updated api/v1/swagger/definitions/suggestion.yaml
- Updated Koha::Suggestion->to_api_mapping

Test plan:
1. Run API tests: prove t/db_dependent/api/v1/suggestions.t
2. Verify suggestions API continues to work correctly
3. Check that item_type_id field is properly mapped in API responses

-- 
You are receiving this mail because:
You are watching all bug changes.
_______________________________________________
Koha-bugs mailing list -- [email protected]
To unsubscribe send an email to [email protected]
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to