https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43623

--- Comment #2 from Jonathan Druart <[email protected]> ---
Created attachment 206813
  -->
https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=206813&action=edit
Bug 43623: Support LIMIT ... OFFSET ... syntax in SQL reports

strip_limit only recognized "LIMIT count" and "LIMIT offset, count". A
report using "LIMIT count OFFSET offset" kept its OFFSET clause, and
execute_query then appended "LIMIT ?, ?" to it, resulting in a SQL syntax
error.

Test plan:
1. Create a SQL report: SELECT itemnumber FROM items LIMIT 50 OFFSET 100
2. Run it => SQL syntax error near 'LIMIT 0, 50'
3. Apply this patch
4. Run the report again => 50 items are displayed, the same as in the
   database console
5. prove t/db_dependent/Reports/Guided.t

Co-Authored-By: Claude Opus 5.5 <[email protected]>

-- 
You are receiving this mail because:
You are watching all bug changes.
You are the assignee for the bug.
_______________________________________________
Koha-bugs mailing list -- [email protected]
To unsubscribe send an email to [email protected]
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to