Hi!
I'm having issues with a freshly installed debian server on which I put a 17.05.06 koha. Plack just won't start. In the logs I had


Error while loading /installdir/etc/plack.psgi: Can't load application from file "/gitdir/api/v1/app.pl": Can't locate object method "cache_dir" via package "Swagger2::SchemaValidator" at /usr/share/perl5/Swagger2.pm line 41.

After futile attemps, I then "solved" it by upgrading Swagger2 (manually) to 0.89. It "solved" it, then appeared

Error while loading /installdir/etc/plack.psgi: Can't load application from file "/gitdir/api/v1/app.pl": Can't locate object method "data" via package "Mojo::URL" at /usr/local/share/perl/5.20.2/Swagger2.pm line 47

Mojo and Mojolicious and everything else I check seem to be at their latest version. No patch from the community (for 17.11+) seem related.

Of course, that doesn't happen on my other servers, but they are "old", so somewhere a .pm is different for sure.

Any suggestion?
--
Philippe Blouin,
Responsable du développement informatique

Tél.  : (888) 604-2627
philippe.blo...@inlibro.com <mailto:philippe.blo...@inlibro.com>

inLibro | pour esprit libre | www.inLibro.com <http://www.inLibro.com>
_______________________________________________
Koha-devel mailing list
Koha-devel@lists.koha-community.org
http://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to