Hi all,

 

I just tried to work on Koha master on OpenSUSE 42.3, which was released on
2017-07-26, but I'm being prevented from installing Koha, because OpenSUSE
42.3 uses Perl 5.18.2 rather than Perl 5.20. 

 

I tracked the change back to
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20104. The claim
was that C4::Log::cronlogaction uses caller and that caller doesn't exist
before Perl 5.20, but that's not true. The caller function has been in Perl
for an extremely long time. You can find it in RHEL 6.9 which uses Perl
5.10. I just used it in Perl 5.18.2. So that doesn't seem like a good
justification for requiring a minimum version of Perl 5.20.

 

I have a feeling that this change is going to bite other people developing
and using Koha around the world. There are people running Koha on openSUSE,
Suse Enterprise Linux, Fedora, Red Hat, CentOS. probably other distros as
well. Are we really going to exclude everyone that doesn't use recent
Debian-based distros from using newer versions of Koha?

 

It seems to me that this decision was made without community discussion.
Maybe I'm wrong, but I figured I'd bring it up with everyone. 

 

For my part, I'm just going to hack around this requirement for now, but I
don't really like that as a long-term solution. 

 

What does everyone else think?

 

David Cook

Systems Librarian

Prosentient Systems

72/330 Wattle St

Ultimo, NSW 2007

Australia

 

Office: 02 9212 0899

Direct: 02 8005 0595

 

_______________________________________________
Koha-devel mailing list
Koha-devel@lists.koha-community.org
http://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-devel
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to