Hi Katrin,

Thanks for your suggestion. Apologies for the delay in replying but we saw
our first sunshine in weeks today so we were making the most of it!

I have tried deleting the javascript in "intranetuserjs" but it makes no
difference, all item searches still show the same error. I don't think
there is any custom javascript lurking in any of the other sysprefs.

The error message I reported appears immediately, not even the table
headings on the results page are shown.

The problem is not present on our training system running Koha 17.05

=====

Just in case it helps, I did a diff on the 17.05 and 17.11 versions of the
file /usr/share/koha/intranet/cgi-bin/catalogue/itemsearch.pl which is the
file displaying the error. The output is shown below, though these
differences don't seem related to the error I'm seeing.

Any other suggestions gratefully received. Can anyone else reproduce the
error, perhaps?

Best Regards,

Chris Brown

====== Here's the diff output =====

30a31
> use Koha::Biblios;
63,64d63
<                 push @q, "%$word%";
<                 push @op, 'like';
65a65,72
>
>                 if ( grep /^$columns[$i]$/, qw( ccode homebranch
holdingbranch location notforloan ) ) {
>                     push @q, "$word";
>                     push @op, '=';
>                 } else {
>                     push @q, "%$word%";
>                     push @op, 'like';
>                 }
229c236
<             $item->{biblio} = GetBiblio($item->{biblionumber});
---
>             $item->{biblio} = Koha::Biblios->find( $item->{biblionumber}
);

========


On Sat, Apr 14, 2018 at 6:59 AM, Katrin Fischer <katrin.fischer...@web.de>
wrote:

> Hi Chris,
>
> try removing the JavaScript from the system preference to see if it makes
> a difference. Sometimes custom JavaScript can have unwanted side effects.
> That way we can limit it down a bit more.
>
> Katrin
>
>
> On 14.04.2018 07:48, Chris Brown wrote:
>
>> Hi Jonathan,
>>
>> Thank you for your prompt reply. However, I cannot find any syspref that
>> appears to be related to enabling / disabling javascript.
>>
>> I am fairly sure that javascript is "turned on" because I have some code
>> in
>> the syspref "IntranetUserJS" that is working. I have also verified that
>> javascript is enabled in my browser.
>>
>> Please could you be more explicit about how I make the change you suggest?
>>
>> Best Regards,
>>
>> Chris Brown
>>
>>
>> On Fri, Apr 13, 2018 at 6:10 PM, Jonathan Druart <
>> jonathan.dru...@bugs.koha-community.org> wrote:
>>
>> Enable Javascript (i.e. disable NoScript).
>>>
>>> On Fri, 13 Apr 2018 at 13:47 Chris Brown <ch...@stayawake.co.uk> wrote:
>>>
>>> Hello,
>>>>
>>>> We are seeing the following error when doing an "item search" in Koha
>>>> 17.11. We've tried searching on barcode and on author but always see the
>>>> same message.
>>>>
>>>> Our training system (running Koha 17.05) does not show this error.
>>>>
>>>> Is this a bug or are we perhaps doing something wrong?
>>>>
>>>> Thanks!
>>>>
>>>> Chris Brown
>>>>
>>>> Software error:
>>>>
>>>> Unsupported format html at
>>>> /usr/share/koha/intranet/cgi-bin/catalogue/itemsearch.pl line 42.
>>>> _______________________________________________
>>>> Koha mailing list  http://koha-community.org
>>>> Koha@lists.katipo.co.nz
>>>> https://lists.katipo.co.nz/mailman/listinfo/koha
>>>>
>>>> _______________________________________________
>> Koha mailing list  http://koha-community.org
>> Koha@lists.katipo.co.nz
>> https://lists.katipo.co.nz/mailman/listinfo/koha
>>
>
> _______________________________________________
> Koha mailing list  http://koha-community.org
> Koha@lists.katipo.co.nz
> https://lists.katipo.co.nz/mailman/listinfo/koha
>
_______________________________________________
Koha mailing list  http://koha-community.org
Koha@lists.katipo.co.nz
https://lists.katipo.co.nz/mailman/listinfo/koha

Reply via email to