ugh.

I'm looking at what it would take to make a "load component from XML"
method for class component and I'm reminded that I had made a bunch of
robustness enhancements to something in that part of the source tree but
I forgot which class it was in. something about removing a cached
pointer in favor of an accessor method to eliminate the possibility of a
certain type of pointer bug and in order to make the debugging output
more readable.. where'dIputthatcode....

I've also started sketching out a prototype XML format.

-- 
Opera: Sing it loud! :o(  )>-<
<?xml version='1.0' encoding='UTF-8'?>
<electronic_part xmlns="electronics" inherits_from="somePartName" part_description="foobarnator" >
  <Description contacts="2" parameters="1" nodes="1" >
    <contact1 input="" />
    <node1 foobisity="3" />
<!--General description of the part, for allocating simulator resources,
elements may specify information about pins/elements, always assumes nodes = nodes + contacts
-->  </Description>
  <theory>
<!--equations of operation -- may just inherit from parent
-->  </theory>
  <limits>
<!--limiting parameters and some function which generates them, could be constant.
-->  </limits>
</electronic_part>
-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Ktechlab-devel mailing list
Ktechlab-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ktechlab-devel

Reply via email to