On Monday, November 13, 2017 at 7:07:48 PM UTC-6, steven....@versussystems.com 
wrote:
> github issue: https://github.com/kubernetes/ingress-gce/issues/75
> ```
> googleapi: Error 400: Invalid value for field 'namedPorts[12].port': '0'. 
> Must be greater than or equal to 1, invalid
> ```
> 
> All ingress already created still work, besides the error, but when I create 
> a new one, I get the same error and the new one doesn't work.
> 
> I'm not exactly sure what triggered it, but I updated to 1.8.2 recently.
> 
> This is my ingress
> ```
> apiVersion: extensions/v1beta1
> kind: Ingress
> metadata:
>   annotations:
>     ingress.gcp.kubernetes.io/pre-shared-cert: star-versussystems-com
>     ingress.kubernetes.io/force-ssl-redirect: "true"
>     kubernetes.io/ingress.allow-http: "false"
>     kubernetes.io/ingress.global-static-ip-name: coreserver-sdk-develop
>   creationTimestamp: 2017-11-09T18:36:40Z
>   generation: 1
>   labels:
>     app: coreserver
>     chart: coreserver-0.1.0
>     heritage: Tiller
>     release: coreserver-sdk-develop
>   name: coreserver-sdk-develop
>   namespace: develop
>   resourceVersion: "11786409"
>   selfLink: 
> /apis/extensions/v1beta1/namespaces/develop/ingresses/coreserver-sdk-develop
> spec:
>   backend:
>     serviceName: coreserver-sdk-develop
>     servicePort: 80
>   rules:
>   - host: coreserver-sdk-develop.versussystems.com
>     http:
>       paths:
>       - backend:
>           serviceName: coreserver-sdk-develop
>           servicePort: 80
> status:
>   loadBalancer: {}
> ```
> 
> ```
> $ kubectl version
> Client Version: version.Info{Major:"1", Minor:"7", GitVersion:"v1.7.6", 
> GitCommit:"4bc5e7f9a6c25dc4c03d4d656f2cefd21540e28c", GitTreeState:"clean", 
> BuildDate:"2017-09-14T06:55:55Z", GoVersion:"go1.8.3", Compiler:"gc", 
> Platform:"darwin/amd64"}
> Server Version: version.Info{Major:"1", Minor:"8+", 
> GitVersion:"v1.8.2-gke.0", 
> GitCommit:"52ea03646e64b35a5b092ab32bb529400c296aa6", GitTreeState:"clean", 
> BuildDate:"2017-10-24T23:31:18Z", GoVersion:"go1.8.3b4", Compiler:"gc", 
> Platform:"linux/amd64"}
> ```
> 
> Any ideas?
> 
> 
> What do you guys think?

I was able to solve it by adding an annotation to disable the Google LB for my 
service.

kubernetes.io/ingress.class: "nginx"

http://blog.chronos-technology.nl/post/disabling-gke-load-balancer-in-kubernetes/

-- 
You received this message because you are subscribed to the Google Groups 
"Kubernetes user discussion and Q&A" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to kubernetes-users+unsubscr...@googlegroups.com.
To post to this group, send email to kubernetes-users@googlegroups.com.
Visit this group at https://groups.google.com/group/kubernetes-users.
For more options, visit https://groups.google.com/d/optout.

Reply via email to