Hi Sunhil,
I did something like this in my ingress, but problem occures even if there 
is no ingresses at all. It's log related to nginx ingress controller 
<https://github.com/kubernetes/ingress-nginx>. I'm stucked, any idea?

понедељак, 16. април 2018. 15.27.01 UTC+2, Sunil Bhai је написао/ла:
>
> Hi Dusan,
>
> Let me know if you have defined Ingress services as below
>
> Kindly check this once - 
> https://kubernetes.io/docs/concepts/services-networking/ingress/
>
> *apiVersion: extensions/v1beta1 kind: Ingress metadata: name: test-ingress 
> annotations: nginx.ingress.kubernetes.io/rewrite-target 
> <http://nginx.ingress.kubernetes.io/rewrite-target>: / spec: rules: - http: 
> paths: - path: /testpath backend: serviceName: test servicePort: 80 *
>
>
>
>
> On Monday, April 16, 2018 at 6:46:04 PM UTC+5:30, Dušan Borovčanin wrote:
>
>> Hi,
>>
>> I've been following instructions provided here 
>> <https://github.com/kubernetes/ingress-nginx/blob/master/deploy/README.md>. 
>> I've been using default configs provided in *mandatory commands *section 
>> and *install without RBC roles. *However, when I run all the commands 
>> provided, Nginx ingress controller starta and I got this log message:
>>
>>> controller.go:647] error creating upstream default-nginx-service-90: 
>>> error getting service default/nginx-service from the cache: service 
>>> default/nginx-service was not found
>>>
>>  I do not provide any *nginx-service *service since it's not marekd as 
>> requirement in this instructions. I\ve been working on this for couple of 
>> days, but problem still occures. Can anyone help me, I have no idea what's 
>> going on?
>>
>> Thanks,
>> Dusan
>>
>
понедељак, 16. април 2018. 15.27.01 UTC+2, Sunil Bhai је написао/ла:
>
> Hi Dusan,
>
> Let me know if you have defined Ingress services as below
>
> Kindly check this once - 
> https://kubernetes.io/docs/concepts/services-networking/ingress/
>
> *apiVersion: extensions/v1beta1 kind: Ingress metadata: name: test-ingress 
> annotations: nginx.ingress.kubernetes.io/rewrite-target 
> <http://nginx.ingress.kubernetes.io/rewrite-target>: / spec: rules: - http: 
> paths: - path: /testpath backend: serviceName: test servicePort: 80 *
>
>
>
>
> On Monday, April 16, 2018 at 6:46:04 PM UTC+5:30, Dušan Borovčanin wrote:
>
>> Hi,
>>
>> I've been following instructions provided here 
>> <https://github.com/kubernetes/ingress-nginx/blob/master/deploy/README.md>. 
>> I've been using default configs provided in *mandatory commands *section 
>> and *install without RBC roles. *However, when I run all the commands 
>> provided, Nginx ingress controller starta and I got this log message:
>>
>>> controller.go:647] error creating upstream default-nginx-service-90: 
>>> error getting service default/nginx-service from the cache: service 
>>> default/nginx-service was not found
>>>
>>  I do not provide any *nginx-service *service since it's not marekd as 
>> requirement in this instructions. I\ve been working on this for couple of 
>> days, but problem still occures. Can anyone help me, I have no idea what's 
>> going on?
>>
>> Thanks,
>> Dusan
>>
>
понедељак, 16. април 2018. 15.27.01 UTC+2, Sunil Bhai је написао/ла:
>
> Hi Dusan,
>
> Let me know if you have defined Ingress services as below
>
> Kindly check this once - 
> https://kubernetes.io/docs/concepts/services-networking/ingress/
>
> *apiVersion: extensions/v1beta1 kind: Ingress metadata: name: test-ingress 
> annotations: nginx.ingress.kubernetes.io/rewrite-target 
> <http://nginx.ingress.kubernetes.io/rewrite-target>: / spec: rules: - http: 
> paths: - path: /testpath backend: serviceName: test servicePort: 80 *
>
>
>
>
> On Monday, April 16, 2018 at 6:46:04 PM UTC+5:30, Dušan Borovčanin wrote:
>
>> Hi,
>>
>> I've been following instructions provided here 
>> <https://github.com/kubernetes/ingress-nginx/blob/master/deploy/README.md>. 
>> I've been using default configs provided in *mandatory commands *section 
>> and *install without RBC roles. *However, when I run all the commands 
>> provided, Nginx ingress controller starta and I got this log message:
>>
>>> controller.go:647] error creating upstream default-nginx-service-90: 
>>> error getting service default/nginx-service from the cache: service 
>>> default/nginx-service was not found
>>>
>>  I do not provide any *nginx-service *service since it's not marekd as 
>> requirement in this instructions. I\ve been working on this for couple of 
>> days, but problem still occures. Can anyone help me, I have no idea what's 
>> going on?
>>
>> Thanks,
>> Dusan
>>
>

-- 
You received this message because you are subscribed to the Google Groups 
"Kubernetes user discussion and Q&A" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to kubernetes-users+unsubscr...@googlegroups.com.
To post to this group, send email to kubernetes-users@googlegroups.com.
Visit this group at https://groups.google.com/group/kubernetes-users.
For more options, visit https://groups.google.com/d/optout.

Reply via email to