Amit Shah <[EMAIL PROTECTED]> writes: > + > +static struct page *page; > +static unsigned long page_gfn; Bad variable names
> + > +const struct dma_mapping_ops *orig_dma_ops; I suspect real dma ops stacking will need some further thought than your simple hacks > + > + match = find_matching_pt_dev(&pt_devs_head, &pv_pci_info); > + if (match) { > + r = match->is_pv; > + goto out; > + } > + > + memcpy(page_address(page), &pv_pci_info, sizeof(pv_pci_info)); Note that on 32bit page_address() might be not mapped. > + > + npages = get_order(size) + 1; Are you sure that's correct? It looks quite bogus. order is a 2 logarithm, normally npages = 1 << order if you want npages from order the correct need 1 << order Haven't read further, but to be honest the code doesn't seem to be anywhere near merging quality. -Andi ------------------------------------------------------------------------- This SF.net email is sponsored by the 2008 JavaOne(SM) Conference Don't miss this year's exciting event. There's still time to save $100. Use priority code J8TL2D2. http://ad.doubleclick.net/clk;198757673;13503038;p?http://java.sun.com/javaone _______________________________________________ kvm-devel mailing list kvm-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/kvm-devel