* On Tuesday 29 Jul 2008 12:44:17 Yang, Sheng wrote:
> On Tuesday 29 July 2008 00:26:25 Ben-Ami Yassour wrote:
> > FROM: Avi Kivity <[EMAIL PROTECTED]>
> >
> > This can be used by kvm subsystems that are interested in when
> > interrupts
> > are acked, for example time drift compenstation.
> >
> > [Ben: add notification call to the pic and ioapic]
> >
> > Signed-off-by: Avi Kivity <[EMAIL PROTECTED]>
> > Signed-off-by: Ben-Ami Yassour <[EMAIL PROTECTED]>
> > ---
> >  arch/x86/kvm/i8259.c       |    1 +
> >  arch/x86/kvm/irq.c         |   22 ++++++++++++++++++++++
> >  arch/x86/kvm/irq.h         |    5 +++++
> >  include/asm-x86/kvm_host.h |    7 +++++++
> >  virt/kvm/ioapic.c          |    2 ++
> >  5 files changed, 37 insertions(+), 0 deletions(-)
> >
> > diff --git a/arch/x86/kvm/i8259.c b/arch/x86/kvm/i8259.c
> > index 55e179a..d2a61bf 100644
> > --- a/arch/x86/kvm/i8259.c
> > +++ b/arch/x86/kvm/i8259.c
> > @@ -186,6 +186,7 @@ int kvm_pic_read_irq(struct kvm_pic *s)
> >             irq = 7;
> >             intno = s->pics[0].irq_base + irq;
> >     }
> > +   kvm_notify_acked_irq(s->irq_request_opaque, irq);
>
> It's not what I mean, sorry to not tell it clearly... Now it got
> confusing semantic.
>
> irq_request_opaque has nothing to do with acked_irq. What I mean is

The change here uses the irq_request_opaque field which actually is the kvm 
struct, pointed out by you, thanks for that.

> rename irq_request_opaque to struct* kvm in struct kvm_pic, and
> modify all irq_request() calling(three of them in all) with (void
> *)kvm.

'opaque' fields can be later made to point to other structures without 
changing the structure itself. This is an advantage. Will the kvm_pic struct 
be needed to change in the future? Very unlikely. So we can rename it to 
struct kvm *, however, that gives us no real benefit as against opaque (just 
readability).

Amit
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to