On Mon, Oct 05, 2009 at 05:38:35PM +0200, Avi Kivity wrote:
> On 10/05/2009 11:46 AM, Michael S. Tsirkin wrote:
>> Update headers from linux 2.6.32-rc1, this mainly
>> adds irqfd which will make it easier to add vhost,
>> down the line. Also reduce code duplication by including
>> kvm_types.h instead of copying it.
>>
>> Signed-off-by: Michael S. Tsirkin<m...@redhat.com>
>> ---
>>   kvm/include/linux/kvm.h        |  131 +++++++++++++++----------------------
>>   kvm/include/linux/kvm_para.h   |   56 +---------------
>>   kvm/include/x86/asm/kvm.h      |   46 +------------
>>   kvm/include/x86/asm/kvm_para.h |  141 
>> +---------------------------------------
>>   4 files changed, 61 insertions(+), 313 deletions(-)
>>
>> diff --git a/kvm/include/linux/kvm.h b/kvm/include/linux/kvm.h
>> index 801865d..2c9a209 100644
>> --- a/kvm/include/linux/kvm.h
>> +++ b/kvm/include/linux/kvm.h
>> @@ -1,43 +1,4 @@
>> -#ifndef KVM_UNIFDEF_H
>> -#define KVM_UNIFDEF_H
>> -
>> -#ifdef __i386__
>> -#ifndef CONFIG_X86_32
>> -#define CONFIG_X86_32 1
>> -#endif
>> -#endif
>> -
>> -#ifdef __x86_64__
>> -#ifndef CONFIG_X86_64
>> -#define CONFIG_X86_64 1
>> -#endif
>> -#endif
>> -
>> -#if defined(__i386__) || defined (__x86_64__)
>> -#ifndef CONFIG_X86
>> -#define CONFIG_X86 1
>> -#endif
>> -#endif
>> -
>> -#ifdef __ia64__
>> -#ifndef CONFIG_IA64
>> -#define CONFIG_IA64 1
>> -#endif
>> -#endif
>> -
>> -#ifdef __PPC__
>> -#ifndef CONFIG_PPC
>> -#define CONFIG_PPC 1
>> -#endif
>> -#endif
>> -
>> -#ifdef __s390__
>> -#ifndef CONFIG_S390
>> -#define CONFIG_S390 1
>> -#endif
>> -#endif
>> -
>> -#endif
>>    
>
> Why are you dropping these?  Any dependencies on CONFIG_ will be broken.

Instead I included kvm_types which has these.

>
> Or is this the output of 'make headers_install'?

yes. I just added include to kvm_types to add the CONFIG_ stuff.
Or maybe instead we should fix users to depend on the correct ifdefs.

> -- 
> error compiling committee.c: too many arguments to function
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to