(2011/12/12 13:51), Xiao Guangrong wrote:
On 12/12/2011 12:04 PM, Takuya Yoshikawa wrote:

(2011/12/12 12:16), Xiao Guangrong wrote:
On 12/12/2011 06:24 AM, Takuya Yoshikawa wrote:

From: Takuya Yoshikawa<yoshikawa.tak...@oss.ntt.co.jp>

Make it clear that this is not related to virtual memory.



'vm' means 'virtual machine'...

Of course I know.  So I wrote "not related" to virtual memory.

What's your point?



In the code, we have kvm_create_vm()/kvm_destroy_vm(), then
add/delete the 'vm" to/from the "vm_list", it is really clear,
so i think this name is OK. :)


Some reasons I wanted to change this:

        - The lock which protects this list is called kvm_lock, not vm_lock
        - Some architectures are using vm_list for vm region member
        - The list connects kvm instances (struct kvm) and we are doing
          list_for_each_entry(kvm, &vm_list, vm_list), not
          list_for_each_entry(vm, &vm_list, vm_list)

In the case of kvm_create_vm(), it creates not only a kvm instance but also
does more virtual machine initialization generally.  So _vm is reasonable.
(I do not mind if it is static in kvm_main.c but it is more widely used.)


But I do not mind to drop this patch if other people also want to keep the
name.  So I will wait some more comments.


Thanks,
        Takuya
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to