Il 08/12/2013 12:33, Vadim Rozenfeld ha scritto:
> +             tsc_ref.tsc_sequence =
> +                     boot_cpu_has(X86_FEATURE_CONSTANT_TSC) ? 1 : 0;
> +             tsc_ref.tsc_scale =
> +                     ((10000LL << 32) / vcpu->arch.virtual_tsc_khz) << 32;
> +             tsc_ref.tsc_offset = 0;
>               if (__copy_to_user((void __user *)addr, &tsc_ref, 
> sizeof(tsc_ref)))
>                       return 1;
>               mark_page_dirty(kvm, gfn);
>               kvm->arch.hv_tsc_page = data;
> +             kvm->arch.hv_ref_count = 0;
>               break;
>       }
>       default:
> @@ -3879,6 +3884,19 @@ long kvm_arch_vm_ioctl(struct file *filp,
>               local_irq_enable();
>               kvm->arch.kvmclock_offset = delta;
>               kvm_gen_update_masterclock(kvm);
> +
> +             if (kvm->arch.hv_tsc_page & HV_X64_MSR_TSC_REFERENCE_ENABLE) {
> +                     HV_REFERENCE_TSC_PAGE* tsc_ref;
> +                     u64 curr_time;
> +                     tsc_ref = (HV_REFERENCE_TSC_PAGE*)gfn_to_hva(kvm, 
> +                             kvm->arch.hv_tsc_page >> 
> HV_X64_MSR_TSC_REFERENCE_ADDRESS_SHIFT);
> +                     tsc_ref->tsc_sequence =
> +                             boot_cpu_has(X86_FEATURE_CONSTANT_TSC) ? 
> tsc_ref->tsc_sequence + 1 : 0;
> +                     tsc_ref->tsc_scale = ((10000LL << 32) / 
> __get_cpu_var(cpu_tsc_khz)) << 32;

Why shouldn't this be vcpu->arch.virtual_tsc_khz?

> +                     curr_time = (((tsc_ref->tsc_scale >> 32) * 
> native_read_tsc()) >> 32) + 
> +                             tsc_ref->tsc_offset;
> +                     tsc_ref->tsc_offset = kvm->arch.hv_ref_time - curr_time;
> +             }

The difference in setting tsc_ref->tsc_scale is the only important
change between the two occurrences.  If you can avoid that difference
and you move this to a separate function, you can reuse that new
function in set_msr_hyperv_pw as well.

Also, kvm_set_tsc_khz should recompute the reference page's values as
well, so you'd have three uses.

Paolo
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to