Hi Sebastian,
On 16/10/2019 17:59, Sebastian Andrzej Siewior wrote:
> compute_layout() is invoked as part of an alternative fixup under
> stop_machine(). This function invokes get_random_long() which acquires a
> sleeping lock on -RT which can not be acquired in this context.
> Rename compute_layout() to kvm_compute_layout() and invoke it before
> stop_machines() invokes the fixups.
Nit: stop_machine() applies the alternatives.
> Add a __init prefix to
> kvm_compute_layout() because the caller has it, too (and so the code can
> be discarded after boot).
> diff --git a/arch/arm64/include/asm/alternative.h
> b/arch/arm64/include/asm/alternative.h
> index b9f8d787eea9f..7532f044d713b 100644
> --- a/arch/arm64/include/asm/alternative.h
> +++ b/arch/arm64/include/asm/alternative.h
> @@ -35,6 +35,12 @@ void apply_alternatives_module(void *start, size_t length);
> static inline void apply_alternatives_module(void *start, size_t length) { }
> #endif
>
> +#ifdef CONFIG_KVM_ARM_HOST
> +void kvm_compute_layout(void);
> +#else
> +static inline void kvm_compute_layout(void) { }
> +#endif
I don't think alternative.h is where this belongs... Could you move it to
kvm_mmu.h, which
is where the kvm_update_va_mask macro that depends on it lives.
You can avoid the #ifdef if you use if(IS_ENABLED()) in the caller.
This has the advantage that the compiler will catch invalid C regardless of the
build
options. (and its easier on the eye)
> diff --git a/arch/arm64/kernel/alternative.c b/arch/arm64/kernel/alternative.c
> index d1757ef1b1e74..c28652ee06f64 100644
> --- a/arch/arm64/kernel/alternative.c
> +++ b/arch/arm64/kernel/alternative.c
> @@ -238,6 +238,7 @@ static int __apply_alternatives_multi_stop(void *unused)
> void __init apply_alternatives_all(void)
> {
> /* better not try code patching on a live SMP system */
> + kvm_compute_layout();
> stop_machine(__apply_alternatives_multi_stop, NULL, cpu_online_mask);
> }
This is a funny place to do this kvm check, its not needed to apply the
alternatives.
apply_alternatives_all() is only called from smp_cpus_done(), immediately
before it calls
hyp_mode_check(), could we move it there to live with the 'started at EL2'
message?
(to save you battling the header-jungle: To include asm/kvm_mmu.h, you need to
include
linux/kvm_host.h first)
We end up calling it unconditionally, but I don't think that matters, both
callers do the
right thing.
With that:
Reviewed-by: James Morse <[email protected]>
Thanks,
James
_______________________________________________
kvmarm mailing list
[email protected]
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm