Hi all, Any comments?
Thanks Jianyong > -----Original Message----- > From: Jianyong Wu <[email protected]> > Sent: Thursday, October 24, 2019 7:02 PM > To: [email protected]; [email protected]; [email protected]; > [email protected]; [email protected]; [email protected]; > [email protected]; [email protected]; Mark Rutland > <[email protected]>; [email protected]; Suzuki Poulose > <[email protected]> > Cc: [email protected]; [email protected]; > [email protected]; [email protected]; Steve Capper > <[email protected]>; Kaly Xin (Arm Technology China) > <[email protected]>; Justin He (Arm Technology China) > <[email protected]>; Jianyong Wu (Arm Technology China) > <[email protected]>; nd <[email protected]> > Subject: [RFC PATCH v6 0/7] Enable ptp_kvm for arm64 > > kvm ptp targets to provide high precision time sync between guest and host > in virtualization environment. This patch enable kvm ptp for arm64. > This patch set base on [1][2][3] > > change log: > from v5 to v6: > (1) apply Mark's patch[4] to get SMCCC conduit. > (2) add mechanism to recognize current clocksource by add > clocksouce_id value into struct clocksource instead of method in patch-v5. > (3) rename kvm_arch_ptp_get_clock_fn into > kvm_arch_ptp_get_crosststamp. > > from v4 to v5: > (1) remove hvc delay compensasion as it should leave to userspace. > (2) check current clocksource in hvc call service. > (3) expose current clocksource by adding it to system_time_snapshot. > (4) add helper to check if clocksource is arm_arch_counter. > (5) rename kvm_ptp.c to ptp_kvm_common.c > > from v3 to v4: > (1) fix clocksource of ptp_kvm to arch_sys_counter. > (2) move kvm_arch_ptp_get_clock_fn into arm_arch_timer.c > (3) subtract cntvoff before return cycles from host. > (4) use ktime_get_snapshot instead of getnstimeofday and > get_current_counterval to return time and counter value. > (5) split ktime and counter into two 32-bit block respectively to > avoid > Y2038-safe issue. > (6) set time compensation to device time as half of the delay of hvc > call. > (7) add ARM_ARCH_TIMER as dependency of ptp_kvm for arm64. > > from v2 to v3: > (1) fix some issues in commit log. > (2) add some receivers in send list. > > from v1 to v2: > (1) move arch-specific code from arch/ to driver/ptp/ > (2) offer mechanism to inform userspace if ptp_kvm service is > available. > (3) separate ptp_kvm code for arm64 into hypervisor part and guest > part. > (4) add API to expose monotonic clock and counter value. > (5) refine code: remove no necessary part and reconsitution. > > [1]https://git.kernel.org/pub/scm/linux/kernel/git/will/linux.git/ > commit/?h=kvm/hvc&id=125ea89e4a21e2fc5235410f966a996a1a7148bf > [2]https://git.kernel.org/pub/scm/linux/kernel/git/will/linux.git/ > commit/?h=kvm/hvc&id=464f5a1741e5959c3e4d2be1966ae0093b4dce06 > [3]https://git.kernel.org/pub/scm/linux/kernel/git/will/linux.git/ > commit/?h=kvm/hvc&id=6597490e005d0eeca8ed8c1c1d7b4318ee014681 > [4]https://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git/ > commit/?h=for-next/smccc-conduit- > cleanup&id=6b7fe77c334ae59fed9500140e08f4f896b36871 > > Jianyong Wu (6): > psci: let arm_smccc_1_1_invoke available by modules > ptp: Reorganize ptp_kvm modules to make it arch-independent. > time: Add mechanism to recognize clocksource in time_get_snapshot > psci: Add hvc call service for ptp_kvm. > ptp: arm64: Enable ptp_kvm for arm64 > kvm: arm64: Add capability check extension for ptp_kvm > > Mark Rutland (1): > arm/arm64: smccc/psci: add arm_smccc_1_1_get_conduit() > > drivers/clocksource/arm_arch_timer.c | 24 ++++++ > drivers/firmware/psci/psci.c | 16 ++++ > drivers/ptp/Kconfig | 2 +- > drivers/ptp/Makefile | 1 + > drivers/ptp/ptp_kvm_arm64.c | 53 +++++++++++++ > drivers/ptp/{ptp_kvm.c => ptp_kvm_common.c} | 77 +++++------------- > drivers/ptp/ptp_kvm_x86.c | 87 +++++++++++++++++++++ > include/asm-generic/ptp_kvm.h | 12 +++ > include/clocksource/arm_arch_timer.h | 4 + > include/linux/arm-smccc.h | 30 ++++++- > include/linux/clocksource.h | 6 ++ > include/linux/timekeeping.h | 12 +-- > include/uapi/linux/kvm.h | 1 + > kernel/time/clocksource.c | 3 + > kernel/time/timekeeping.c | 1 + > virt/kvm/arm/arm.c | 1 + > virt/kvm/arm/psci.c | 22 ++++++ > 17 files changed, 286 insertions(+), 66 deletions(-) create mode 100644 > drivers/ptp/ptp_kvm_arm64.c rename drivers/ptp/{ptp_kvm.c => > ptp_kvm_common.c} (63%) create mode 100644 > drivers/ptp/ptp_kvm_x86.c create mode 100644 include/asm- > generic/ptp_kvm.h > > -- > 2.17.1 _______________________________________________ kvmarm mailing list [email protected] https://lists.cs.columbia.edu/mailman/listinfo/kvmarm
