The first two patches are fixes for stuff I found while working on patch
#3.
Patch #3 ("configure: Make the --target option available to all
architectures") was suggested by Drew when he reviewed my series to add
support to run_tests.sh for kvmtool [1] (kvmtool can only be used to run
the arm/arm64 tests). With this patch, now all architecture have --target
as a configure option, with the only valid value being "qemu" (with the
exception of arm and arm64, of course). This was suggested by Drew for two
reasons:
* There's a possibility that kvm-unit-tests will get support for other VMMs
in the future (his example was Rust VMM).
* The changes to the scripts to support kvmtool were rather awkward, as
testing the value of $TARGET was some of the time accompanied by testing
the value of $ARCH.
I renamed --target-efi to --efi-payload in the last patch because I felt it
looked rather confusing to do ./configure --target=qemu --target-efi when
configuring the tests. If the rename is not acceptable, I can think of a
few other options:
1. Rename --target to --vmm. That was actually the original name for the
option, but I changed it because I thought --target was more generic and
that --target=efi would be the way going forward to compile kvm-unit-tests
to run as an EFI payload. I realize now that separating the VMM from
compiling kvm-unit-tests to run as an EFI payload is better, as there can
be multiple VMMs that can run UEFI in a VM. Not many people use kvmtool as
a test runner, so I think the impact on users should be minimal.
2. Keep both option as they are. Personally, I think that would be
confusing to the end user, but I don't have a strong opinion against it.
[1] https://www.spinics.net/lists/kvm/msg247896.html
Alexandru Elisei (4):
configure: Fix whitespaces for the --gen-se-header help text
configure: Restrict --target-efi to x86_64
configure: Make the --target option available to all architectures
Rename --target-efi to --efi-payload
Makefile | 10 +++-------
configure | 45 +++++++++++++++++++++++++++-----------------
lib/x86/acpi.c | 4 ++--
lib/x86/amd_sev.h | 4 ++--
lib/x86/asm/page.h | 8 ++++----
lib/x86/asm/setup.h | 4 ++--
lib/x86/setup.c | 4 ++--
lib/x86/vm.c | 12 ++++++------
scripts/runtime.bash | 4 ++--
x86/Makefile.common | 6 +++---
x86/Makefile.x86_64 | 6 +++---
x86/access_test.c | 2 +-
x86/efi/README.md | 2 +-
x86/efi/run | 2 +-
x86/run | 4 ++--
15 files changed, 62 insertions(+), 55 deletions(-)
--
2.35.1
_______________________________________________
kvmarm mailing list
[email protected]
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm