On Wed, Feb 23, 2022 at 12:55:34PM +0000, Alexandru Elisei wrote:
> The first two patches are fixes for stuff I found while working on patch
> #3.
>
> Patch #3 ("Rename --target-efi to --[enable|disable]-efi") is where the
> configure option --target-efi gets renamed.
>
> Changes in v2:
>
> * Dropped what was patch #3, which made arm/arm64 configure option
> --target available to all architectures.
>
> * Renamed --target-efi to --[enable|disable]-efi instead of --efi-payload.
>
> Alexandru Elisei (3):
> configure: Fix whitespaces for the --gen-se-header help text
> configure: Restrict --target-efi to x86_64
> Rename --target-efi to --[enable|disable]-efi
>
> Makefile | 10 +++-------
> configure | 22 +++++++++++++++-------
> lib/x86/acpi.c | 4 ++--
> lib/x86/amd_sev.h | 4 ++--
> lib/x86/asm/page.h | 8 ++++----
> lib/x86/asm/setup.h | 4 ++--
> lib/x86/setup.c | 4 ++--
> lib/x86/vm.c | 12 ++++++------
> scripts/runtime.bash | 4 ++--
> x86/Makefile.common | 6 +++---
> x86/Makefile.x86_64 | 6 +++---
> x86/access_test.c | 2 +-
> x86/efi/README.md | 2 +-
> x86/efi/run | 2 +-
> x86/run | 4 ++--
> 15 files changed, 49 insertions(+), 45 deletions(-)
>
> --
> 2.35.1
>
Applied to misc/queue and MR posted:
https://gitlab.com/kvm-unit-tests/kvm-unit-tests/-/merge_requests/26
Thanks,
drew
_______________________________________________
kvmarm mailing list
[email protected]
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm