OK, I see. My #ifndef was not good. Seems to work now. I've got the CPU[1]
goes to idle loop :). If you wish, I can send to you the patch to get it
work ?

Marc

Le jeudi 13 octobre 2016, Adam Lackorzynski <a...@os.inf.tu-dresden.de> a
écrit :

> Hi Marc,
>
> On Wed Oct 12, 2016 at 11:17:36 +0200, Marc CHALAND wrote:
> > Le mercredi 12 octobre 2016, Adam Lackorzynski <
> a...@os.inf.tu-dresden.de <javascript:;>
> > <javascript:_e(%7B%7D,'cvml','a...@os.inf.tu-dresden.de <javascript:;>');>>
> a écrit :
> > >
> > > I do not see anything obviously wrong right away. I assume it passes
> the
> > > while loop?
> > >
> >
> > Yes, the while loop exits. In fact, I think uboot powers up core1. I saw
> > some piece of code. So I asserted that core1 starts on tramp func and I
> saw
> > that SCU was manipulated. But I don't understand what is done after.
> > Perhaps it is not compatible with A7 and/or i.MX7 ?
> > I've put a log into boot_ap_cpu() and it is not reached. Is there a way
> to
> > test if something is wrong between tramp_mp_entry and boot_ap_cpu() ?
>
> Ah, remove those few lines that flip that bit on the SCU. It's wrong
> doing that on an A7. Or did you do that already?
> In any case I'll get an i.MX7 in a few days so I can look myself if
> still necessary.
>
>
>
>
> Adam
> --
> Adam                 a...@os.inf.tu-dresden.de <javascript:;>
>   Lackorzynski         http://os.inf.tu-dresden.de/~adam/
>
> _______________________________________________
> l4-hackers mailing list
> l4-hackers@os.inf.tu-dresden.de <javascript:;>
> http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers
>
_______________________________________________
l4-hackers mailing list
l4-hackers@os.inf.tu-dresden.de
http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers

Reply via email to