Why are source_version and parent_source_version returning ''?  I would have 
expected them to return None if there was no such value.

Why not implement getComments directly instead of indirecting through 
IDistroSeriesDifferenceCommentSource?

Your test comments say None, but test for the empty string.  Please fix either 
the test or the comment.

Why assertIs(True, was_updated) instead of assertTrue(was_updated)?  We should 
only care about whether the returned value evaluates to True.  We should 
definitely not care about its identity.

Why assertIs(True, was_updated) instead of 
assertTrue(ds_diff.updateStatusAndType())?  It is shorter, so easier to read.
-- 
https://code.launchpad.net/~michael.nelson/launchpad/distro-series-difference-model/+merge/34086
Your team Launchpad code reviewers is requested to review the proposed merge of 
lp:~michael.nelson/launchpad/distro-series-difference-model into lp:launchpad.

_______________________________________________
Mailing list: https://launchpad.net/~launchpad-reviewers
Post to     : [email protected]
Unsubscribe : https://launchpad.net/~launchpad-reviewers
More help   : https://help.launchpad.net/ListHelp

Reply via email to