Review: Approve

Amazing how this new overriding mechanism is simplifying the code around it. 
Very nice design!

This change improves not only code readability but also correctness, great job.

As discussed on IRC, having proper overrides in NU will have good impacts in 
publications, possibly more cleanups (eg soyuz.model.publishing.get_component) 
and stop {S,B}PR component/section mutation (noted as XXX) and these effects 
will be explored in subsequent MPs.

-- 
https://code.launchpad.net/~wgrant/launchpad/nu-overrides-adapters/+merge/228619
Your team Launchpad code reviewers is subscribed to branch lp:launchpad.

_______________________________________________
Mailing list: https://launchpad.net/~launchpad-reviewers
Post to     : [email protected]
Unsubscribe : https://launchpad.net/~launchpad-reviewers
More help   : https://help.launchpad.net/ListHelp

Reply via email to