Hi,

I started to experiment some more and installed the latest OpenSuse 11.2.
It is really cool otherwise (look at the latest KDE, wow), but when I build 
Lazarus for GTK2 widgets I get error:

Compiling lazarus.pp
Linking ../lazarus
/usr/bin/ld: warning: ../link.res contains output sections; did you forget -T?
/usr/bin/ld: cannot find -lgdk_pixbuf-2.0
lazarus.pp(126,1) Error: Error while linking
lazarus.pp(126,1) Fatal: There were 1 errors compiling module, stopping

However, I have installed gdk_pixbuf.  When I run ldconfig as root, see...

# ldconfig -p | grep gdk_pixbuf
libgvplugin_gdk_pixbuf.so.5 (libc6) => 
/usr/lib/graphviz/libgvplugin_gdk_pixbuf.so.5
libgvplugin_gdk_pixbuf.so (libc6) => 
/usr/lib/graphviz/libgvplugin_gdk_pixbuf.so
libgdk_pixbuf_xlib.so.2 (libc6) => /usr/lib/libgdk_pixbuf_xlib.so.2
libgdk_pixbuf_xlib.so (libc6) => /usr/lib/libgdk_pixbuf_xlib.so
libgdk_pixbuf_xlib-2.0.so.0 (libc6) => /usr/lib/libgdk_pixbuf_xlib-2.0.so.0
libgdk_pixbuf.so.2 (libc6) => /usr/lib/libgdk_pixbuf.so.2
libgdk_pixbuf.so (libc6) => /usr/lib/libgdk_pixbuf.so
libgdk_pixbuf-2.0.so.0 (libc6) => /usr/lib/libgdk_pixbuf-2.0.so.0


Last line should be the one Lazarus needs I think.
Who has Linux? What name the lib has there?

What means warning: "../link.res contains output sections; did you forget -T?"

Earlier there was an error for missing X11 lib but installing X11-devel 
package helped.
Maybe I will try deleting and reloading the whole Lazarus source.

I even installed FPC 2.4.0 RC1 but still get the same error. (I had to ignore 
a dependency for libtinfo.so.5 but that is not a problem. Seems to affect the 
text IDE only, not the compiler).

Other ideas?


Juha Manninen

--
_______________________________________________
Lazarus mailing list
Lazarus@lists.lazarus.freepascal.org
http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus

Reply via email to