On 2016-10-15 18:55, Matthias Schiffer wrote:
On 10/15/2016 06:30 PM, Torbjorn Jansson wrote:
On 2016-10-15 17:39, Matthias Schiffer wrote:
On 10/15/2016 05:19 PM, Matthias Schiffer wrote:
On 10/15/2016 05:04 PM, Torbjorn Jansson wrote:

i decided to give lede a try on one of my rasberry pi computers and i
almost immediately ran into problems.

opkg update works fine, but when i do:
opkg install luci-ssl

i get:

root@lede:~# opkg install luci-ssl
Installing luci-ssl (git-16.288.36935-1e1a706-1) to root...

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for
 *      luci-mod-admin-full *
 * opkg_install_cmd: Cannot install package luci-ssl.

i checked the url and luci-mod-admin-full is indeed missing.
can someone explain whats going on and how to fix it?

a recent patch caused the libnl-tiny build to fail [1], which in turn broke
a lot of other packages that directly or indirectly depend on it.

We're working on fixing this ASAP.


I've just had a closer look at the issue, it was caused by a dependency
issue of our 2-phase build bot setup:

Phase 2 tried to build the packages based on an outdated SDK version, as
Phase 1 has not finished building the newest version the SDK yet. This
broke some packages, as patches depending on SDK changes were added
together with the SDK changes themselves.

The issue will fix itself as soon as the build bots have finished the next
round of builds. Sorry for the inconvenience!

and how often do the build bots rebuild things?
once a day?

Phase 1 rebuilds are triggered for each master commit, but there are many
targets and builds take some time. You can find the current build status on
http://phase1.builds.lede-project.org/grid . Phase 2 builds can be seen on
http://phase2.builds.lede-project.org/grid .

The issue will disappear as soon as phase 1 has finished for your target
(and thus produced a new SDK), and the next phase 2 build after that has
finished, too. This should be done in less than a day.

phase 1 & 2 is done for my target in question (an rpi) but i suspect it was still done in wrong order or something because there is still lots of missing packages including those making luci-ssl work.

and by the way, yesterday i tried to install some kernel modules since they should not have been broken i think.
but it looks like the wifi driver kmod-rtl8192cu depended on hostapd.
how can a kernel module depend on a regular program?
it also the dependency doesn't appear to be there for all wifi modules.

Lede-dev mailing list

Reply via email to