I've been trying to get wifi p2p aka wifi direct working on an ar9331 board.  
[1]  And I'm a little curious whether this has ever worked for anyone at all.
wpad (allegedly "full") doesn't actually include the CONFIG_P2P settings, [2] 
and even after patching it in (along with CONFIG_AP, as per 
http://w1.fi/cgit/hostap/tree/wpa_supplicant/README-P2P I can't get any of the 
p2p commands to work.  "iw phy" indicates that P2P-client and P2P-GO interface 
modes are available.  But nothing in wpa_cli related to p2p works at all.

# wpa_cli -p /var/run/hostapd
Selected interface 'wlan0'
> p2p_find
> ping

"help" shows all the p2p commands being available, but I think that's just 
because this patch blindly turns it on, which seems like a fairly poor patch, I 
can't work out what this patch is really actually trying to do, surely the 
builds should already have the right configurations when they're built? 

I've also tried the original plain wpa-supplicant-p2p package, which presumable 
exists because someone at somepoint had this working, but I get the same 
results, "UNKNOWN COMMAND" on anything p2p related, and infact, _most_ 
commands, not just the p2p commands.

Any ideas?  

Karl Palsson

[1] To avoid xy problem, my goal is to to allow AP+STA style access to a 
device, where the AP remains functional for configuration, even if the STA 
config has the wrong password, or the upstream AP goes away.  This currently 
does _not_ work with regular AP+STA, the AP dies while the STA side continually 
tries to connect and fail
Lede-dev mailing list

Reply via email to