> gl.modify = modify_gl(account1, account2, amount, is_debit)
>   

With a large DB app that I wrote we went for "gl_modify" style instead 
and it was extremely useful in the sense that all the SPs which affect a 
given object then cluster together (alphabetically).  This makes it much 
easier to see if there is something in the API which does what we need 
for "inventory", etc.  eg has someone already written 
"inventory_as_at_date" then it's much easier to find

Most people seem to feel that modify_gl is easier to pronouce than 
gl_modify though...

Ed

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Ledger-smb-devel mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/ledger-smb-devel

Reply via email to