On Sat, Jul 24, 2010 at 11:13 AM, Terry Brown <[email protected]> wrote:

> these are almost duplicates of each other, and I missed the second one.  I've 
> made a trivial change in qtGui.py to eliminate the problem.

DRY (Don't repeat yourself) is a good principle, but it's no panacea.
Refactoring duplicate code *merely* because it is similar is not good
design.  Imo, all code must mean something "real", and refactored code
that merely avoids code duplication might not mean anything.

Edward

-- 
You received this message because you are subscribed to the Google Groups 
"leo-editor" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to 
[email protected].
For more options, visit this group at 
http://groups.google.com/group/leo-editor?hl=en.

Reply via email to