>> On Sat, Dec 15, 2012 at 01:00:38PM +0000, Richard Melville wrote:
>> When I use backspace in the terminal/console and then re-type I get white
>> blocking.  I'm fairly sure that I installed the patches when I built the
>> keyboard package.  Any advice?  It's really annoying.
>> Richard

> I suppose white blocks might be a result of a console font which
> cannot display the glyph it was asked for.  In a unicode font, that
> situation ought to show an inverse question mark (black-on-white for
> normally white-on-black text), but many fonts cannot do that.>>>>>
> However, that doesn't explain why the backspace isn't effective.
> The backspace patch only changes this for a few keymaps which still
> gave Backspace instead of Delete - the last time I looked (some
> time before 1.15.3, so something might have slipped in), all of
> the other keymaps shipped in the package already did this.
> What do you have in /etc/sysconfig/console ?
> ?en

Ken -- thanks for the reply.  I changed the font setting over the weekend
and now it seems to be OK.  The problem was the following: typing worked
OK, and if I made a typo and wanted to delete with the backspace key,
deletion worked OK, however, when I began to type again that's when I saw
the white blocking.

I know very little about fonts, keymaps, unicode, etc.  What I would like
to do is set up a unicode environment but I'm not sure how to go about it,
although I'll probably only be using an accented "e", an umlaut/diaeresis,
and a euro symbol in addition to a uk keymap.  The following are the
console parameters of /etc/sysconfig/rc.site (I'm not using
/etc/sysconfig/console) and I've left my original font setting in, but
commented out:-

# Console parameters
FONT="lat1-16 -m 8859-1"

Thanks for your help.

FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

Reply via email to