On 02/12/2018 07:31 PM, Pierre Labastie wrote:
On 12/02/2018 18:54, Pierre Labastie wrote:
On 11/02/2018 23:01, Tim Tassonis wrote:
On 02/11/2018 10:37 PM, Bruce Dubbs wrote:
Tim Tassonis wrote:

I have found a workaround for my problem:

If I replace

mount -vt devpts devpts $LFS/dev/pts -o gid=5,mode=620


mount -v --bind /dev/pts $LFS/dev/pts

I get the needed /dev/pts/0 and sudo and su with password asking now works.
As it seems that this is really only a chroot issue and su and sudo now
work fine, I'll continue with that. I'm not yet sure of the exact security
implications, but as this is a dedicated vm only for building the system,
it should be ok.

I have the same issue, whether or not I use -o gid=...

After entering chroot, I am root, and if I run "su - pierre", I become pierre.
But if I try to become back root using su (that is running "su -" while being
pierre), I get the "su: must be run from a terminal" message.

Note that if I run (as pierre) "sudo su -", it works (user pierre can sudo
without a password)...

I tried an old LFS (SVN-20160929), and I have exactly the same results...

Hmm, maybe a problem with host (I'm using Debian sid ATM).

I've made a few trials. With kernels older than 4.9, same issue. With 4.7.4,
no issue. That may explain why it was working for older LFS.

s/With kernels older than 4.9/With kernels newer than 4.9/ sorry

Might well be, as I am building under 4.14.16, the last lfs 8.0 build was under 4.9.21.
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Do not top post on this list.

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?


Reply via email to