On Tuesday 31 May 2011 07:09:10 pm Daniel Fazekas wrote:
> On May 31, 2011, at 09:46, augustin wrote:
> > I am trying to securely connect to a server running FTPES:
> > http://ouvaton.coop/spip.php?article376
> > I tried with filezilla and I can connect.
> > But with lftp, the connection hangs at ls:
> > lftp -d sftp://jack.masquilier....@ftp.ocsa-data.net:21
> From the screenshots at your link this doesn't look like an ssh2 sftp
>  server. Using port 21 for sftp would be unusual too. You should try
>  connecting as ftps://…

Thank you Daniel.
Actually, I am very confused by the profusion of protocols. Using wikipedia, I 
have started to summarize the different secure protocols supported by lftp. See 
the table at the bottom of the article:

The official instructions from my host (in French here:
specifically mention using "FTPES - FTP over explicit (TLS/SSL)".

As noted earlier, when I use filezilla with "FTPES - FTP over explicit 
(TLS/SSL)", it works, so I think we can rule out a problem on the server side.

Q1) Does lftp support "FTPES - FTP over explicit (TLS/SSL)"?
My understanding is that it does although FTPES is not listed (FTPS is).

Q2) How to tell lftp to specifically use FTPES?
I tried:

$ lftp -d ftpes://jack.masquilier....@ftp.ocsa-data.net
lftp: ftpes - not supported protocol

Daniel does well to mention the port 21. One of the two screenshots from my 
host (link above) has the port empty, the other shows the port 21.

With port 21 ======> Unknown protocol
ftp -d ftps://jack.masquilier....@ftp.ocsa-data.net:21
Password: lftptest
---- Resolving host address...
---- 1 address found:
lftp jack.masquilier....@ftp.ocsa-data.net:~> ls
---- Connecting to ftp.ocsa-data.net ( port 21
**** SSL_connect: unknown protocol
---- Closing control socket
ls: Fatal error: SSL_connect: unknown protocol
lftp jack.masquilier....@ftp.ocsa-data.net:~> exit

Without any port ========> Connection refused.
lftp -d ftps://jack.masquilier....@ftp.ocsa-data.net
Password: lftptest
---- Resolving host address...
---- 1 address found:
lftp jack.masquilier....@ftp.ocsa-data.net:~> ls
---- Connecting to ftp.ocsa-data.net ( port 990
**** Socket error (Connection refused) - reconnecting
---- Closing control socket
`ls' at 0 [Delaying before reconnect: 21]

======> hangs at 'ls' [connecting]

$ lftp -d sftp://jack.masquilier....@ftp.ocsa-data.net
lftp jack.masquilier....@ftp.ocsa-data.net:~> ls
---- Running connect program (ssh -a -x -s -l jack.masquilier.org ftp.ocsa-
data.net sftp)
---> sending a packet, length=5, type=1(INIT), id=0
`ls' at 0 [Connecting...]

Q3) Given the credentials and password given above, can you try to upload a 
.txt file via FTPES? I'd like to rule out a router setting (no firewall is set, 
but I don't know about port forwarding, if anything needs to be set.)

Q4) Generally speaking, I have been asking around and searching the web, and I 
found many, many posts by people asking similar questions, but mostly without 
any useful answer. My own post at ubuntuforums has remained unanswered... 
because nobody knows.
As noted before, I am documenting things as I go along in the wiki here:
Any hint is welcome about what ought to be documented (especially with regard 
to secure connections).
Yes, I read the man page. It didn't help to clarify any of the confusions I 
had about all the various protocols. I'd like to create a more easy 
understandable tutorial that could be complementary to the man page.



Friends: http://www.reuniting.info/
My projects:
http://astralcity.org/ http://3enjeux.overshoot.tv/ http://linux.overshoot.tv/ 
http://overshoot.tv/ http://charityware.info/ http://masquilier.org/
http://openteacher.info/ http://minguo.info/ 
http://www.wechange.org/ http://searching911.info/


Reply via email to