On Thu, Apr 14, 2016 at 08:59:57PM +0000, Jethro Tull wrote:
> I'm trying to download this file 
> "https://slackbuilds.org/slackbuilds/14.1/office/libreoffice-helppack.tar.gz";.
>  I first tried with lftp -c get 
> "https://slackbuilds.org/slackbuilds/14.1/office/libreoffice-helppack.tar.gz";;
>  It does download something but tar complains that it's not a gzip archive 
> when trying to open it and I tried with wget, it worked well. The file I 
> downloaded with lftp is ~ 10 KB, and the one with wget is ~ 2.6 KB. No need 
> to mention that their md5 are different. I get the same problem with all the 
> other files I tried to download with lftp from "https://slackbuilds/org";, but 
> I have not noticed any problem on the few other https repositories I tried 
> such as "https://www.kernel.org/pub"; and a few archlinux mirrors I found on 
> their website.

Please try a current lftp version (the newest is 4.7.1). The problem is
automatic uncompressing entities with "Content-Encoding: gzip". The
workaround was added in lftp version 4.5.6.

You can also do "set http:decode false" to disable uncompressing.

lftp mailing list

Reply via email to