I have the problem with a FTP server, mirroring is not taking into account any folder for recursion. I think I noticed why: when running ls command, all folders are suffixed with a slash, this doesn't happen on other FTP servers I tried. It seems that this cause lftp to completely ignore them.

dr-x------   3 user group            0 May 11 16:33 folder1/
dr-x------   3 user group            0 May 11 16:33 folder2/
dr-x------   3 user group            0 May 11 16:33 folder3/
dr-x------   3 user group            0 May 11 16:33 folder4/

cls command return an empty list, du gives output "./ 0", as if no folder where present there.

The debug .mplist command gives :

Size=4096;Modify=20170511162938.894;Type=dir;Perm=el; folder1/
Size=4096;Modify=20170511162938.894;Type=dir;Perm=el; folder2/
Size=4096;Modify=20170511162938.894;Type=dir;Perm=el; folder3/
Size=4096;Modify=20170511162938.894;Type=dir;Perm=el; folder4/

I tried to look for some parameter, for instance use-msld or list-options (but what option to provide), but it doesn't change.

Manually changing directory with cd, and mirroring files work correctly.

I can understand that the FTP server is buggy, but is there a way to work around that ? Of course, I have no control over the server, that would be too easy, I have to deal with this, and download data from there...

Thank you !

lftp mailing list

Reply via email to