On 2012-10-05 08:27:11 +0200, Anton Khirnov wrote: > > On Fri, 21 Sep 2012 11:23:31 -0400, Justin Ruggles <[email protected]> > wrote: > > --- > > libavcodec/aacdec.c | 36 +++++++++++++----------------------- > > libavcodec/aacsbr.c | 5 ++--- > > 2 files changed, 15 insertions(+), 26 deletions(-) > > > > diff --git a/libavcodec/aacdec.c b/libavcodec/aacdec.c > > index 1c59ec5..385c8ae 100644 > > --- a/libavcodec/aacdec.c > > +++ b/libavcodec/aacdec.c > > @@ -843,13 +843,8 @@ static av_cold int aac_decode_init(AVCodecContext > > *avctx) > > } > > } > > > > - if (avctx->request_sample_fmt == AV_SAMPLE_FMT_FLT) { > > - avctx->sample_fmt = AV_SAMPLE_FMT_FLT; > > - output_scale_factor = 1.0 / 32768.0; > > - } else { > > - avctx->sample_fmt = AV_SAMPLE_FMT_S16; > > - output_scale_factor = 1.0; > > - } > > + avctx->sample_fmt = AV_SAMPLE_FMT_FLTP; > > + output_scale_factor = 1.0 / 32768.0; > > > > AAC_INIT_VLC_STATIC( 0, 304); > > AAC_INIT_VLC_STATIC( 1, 270); > > @@ -2473,6 +2468,8 @@ static int aac_decode_frame_int(AVCodecContext > > *avctx, void *data, > > The function name is a bit strange when output is float. Or is it > referring to something different?
yes, internal. Janne _______________________________________________ libav-devel mailing list [email protected] https://lists.libav.org/mailman/listinfo/libav-devel
