On Tue, 23 Oct 2012 21:55:13 +0200, Diego Biurrun <[email protected]> wrote:
> On Tue, Oct 23, 2012 at 09:40:08PM +0200, Anton Khirnov wrote:
> > --- a/doc/filters.texi
> > +++ b/doc/filters.texi
> > @@ -175,6 +175,47 @@ stream ends. The default value is 2 seconds.
> > +
> > +@item pts
> > +presentation timestamp of the input frame, in time base units. The time
> > base
> > +depends on the filter input pad, and is usually 1/@var{sample_rate}.
>
> Start capitalized and replace the period by a semicolon.
>
??
Doing both conflicts with all that I consider to be good and just.
Either it is a proper sentence, then it starts capitalized and ends with a
period. Or it is not a proper sentence, just a short description or whatever. In
which case there is no need for it to start capitalized.
> > +@item pts_time
> > +presentation timestamp of the input frame in seconds.
>
> s/.//
>
> > +@item plane_checksums
> > +A list of Adler-32 checksums for each data plane.
>
> ditto - and lowercase, no verb in sight
>
> > --- /dev/null
> > +++ b/libavfilter/af_ashowinfo.c
> > @@ -0,0 +1,135 @@
> > +
> > +#include <inttypes.h>
> > +#include <stdint.h>
> > +#include <stddef.h>
>
> Just inttypes.h should suffice, whatever ...
>
Fixed locally
> > +typedef struct AShowInfoContext {
> > + /**
> > + * Scrach space for individual plane checksums for planar audio
>
> scra_t_ch
Fixed locally
>
> > + s->plane_checksums[i] = av_adler32_update(0, data, data_size);
> > + checksum = i ? av_adler32_update(checksum, data, data_size) :
> > + s->plane_checksums[0];
>
> nit: : below ? is more readable
I tend to disagree
--
Anton Khirnov
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel