Hi, just realized I totally forgot to reply to your private mail. Very sorry about that, I've been terribly busy and simply forgot.
On Mon, 09 Dec 2013 11:26:43 -0500, Keith Lawson <[email protected]> wrote: > On 2013-12-09 10:51, Luca Barbato wrote: > > > On 09/12/13 15:16, [email protected]: > > > >> From: Keith Lawson <[email protected]> --- I created this > >> patch to make the action for EOF on the secondary input configurable > >> with the overlay filter so I could use a filtergraph that combines the > >> trim, delogo and overlay filters into a filtergraph to "mask" a > >> portion of a video like this: I've tested the command above and it > >> works for masking most portions of videos however I'm encountering > >> problems masking near the end of videos. avconv quickly consumes all > >> memory and swap sometimes when the trim range is near the end of the > >> video. The process eventually finishes but there's obviously a memory > >> issue. I'm hoping someone can assist me in troubleshooting that > >> problem. > > > > This seems quite an annoying bug > > > > It definitely is. So far I'm unable to reproduce it reliably so once I > have an example I'll post the video files and command line I'm using. > Unfortunately so far all the videos I've encountered this on are for one > of my customers and contain confidential information. > The problem is most likely not caused by your patch, so it can go in without fixing the bug first (though it'd certainly be nice) > >> I'd like to complete the work required to have the new switch added to > >> the master repository so I'm submitting it here for review. I haven't > >> documented the new switch yet so pointers to how to do that would be > >> helpful. > > > > Probably the naming might be changed since took me a bit to match > > seofact with it, the idea itself is sound and we should get this in =) > > > > Do you mean change the name of the switch? I'm open to suggestions that > are more in line with other switch names in the project and easier to > understand. I agree with Luca here, we generally prefer longer names that are easier to understand (shorter aliases can be added where appropriate). Something like 'eof_action' or 'eof_behavior' would be good names IMO -- Anton Khirnov _______________________________________________ libav-devel mailing list [email protected] https://lists.libav.org/mailman/listinfo/libav-devel
