On Wed, 29 Apr 2015, Vittorio Giovara wrote:

On Wed, Apr 29, 2015 at 2:51 PM, Martin Storsjö <[email protected]> wrote:
This is printed in a separate subgroup named "sidedata".
---
This could perhaps also print the complete matrix in itself,
but the output abstraction doesn't (yet) seem to support a raw
array with only numbers, only arrays of name-int pairs. (In the
json output, a plain array of integers would be trivial though,
but it doesn't map quite as well to the ini-style format.)

Suggestions for a better name than displaymatrix_rotation are
welcome, but since we might want to output the full matrix
in itself as well, I chose to include displaymatrix in the name.

Do you think it would make sense to have a "displaymatrix" sub-tree
where to list different properties from the matrix (eg aspect ratio,
flip, transpose etc), or it's better to have displaymatrix_xxx as
needed, to keep things simpler?

For json-style output, it might actually make more sense in that form, while this form might be simpler (i.e. the sidedata field only have got simple values as members, no further dicts embedded). Do others have opinions?

// Martin
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to